Bug 844071 - System tray not working properly
System tray not working properly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cinnamon (Show other bugs)
17
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-28 11:35 EDT by Artyom Kunyov
Modified: 2012-09-29 06:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-29 06:02:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (13.00 KB, image/png)
2012-07-28 11:35 EDT, Artyom Kunyov
no flags Details
keyboard layout applet (6.74 KB, image/png)
2012-09-19 04:06 EDT, Artyom Kunyov
no flags Details

  None (edit)
Description Artyom Kunyov 2012-07-28 11:35:49 EDT
Created attachment 600929 [details]
Screenshot

Description of problem:

I'm using cinnamon 1.5.2 from updates-testing, but there was the same problem with older versions. Can it be a problem that I'm using Catalyst?

Some icons are not showed properly in system tray. Some of they are bigger then they should be, and some are not shown at all.

Look at the screenshot. That thing on the left of Pidgin is Banshee (by the way, Pidgin is now connected, but there's still old icon)
Comment 1 leigh scott 2012-09-19 02:39:47 EDT
Does 1.6.0 fix this issue?
Comment 2 Artyom Kunyov 2012-09-19 04:06:42 EDT
Created attachment 614241 [details]
keyboard layout applet
Comment 3 Artyom Kunyov 2012-09-19 04:08:02 EDT
Yes it does, but there is another problem now.
In 1.6.0, no matter what icon theme I use, keyboard layout applet has a weird icon on the left. See the second screenshot.
Comment 4 leigh scott 2012-09-19 05:42:25 EDT
What cinnamon theme are you using and is it compatible with 1.6.0?
Comment 5 leigh scott 2012-09-19 07:38:27 EDT
(In reply to comment #4)
> What cinnamon theme are you using and is it compatible with 1.6.0?

Default works as expected here.

https://dl.dropbox.com/u/6907158/panel.jpg
Comment 6 Artyom Kunyov 2012-09-19 08:18:42 EDT
I was using Eleganse, but later switched to default, and it still doesn't look as it's supposed too.
http://s1.ipicture.ru/uploads/20120919/vPDVU53c.png

And again, Skype icon got stuck at "connecting" despite the connection is ok. Same thing with Pidgin and others.
Comment 7 Artyom Kunyov 2012-09-19 08:27:32 EDT
Just noticed that the weird icon near keyboard applet disappears after changing layout for the very first time.
Unfortunately, the problem with tray icons still persists, so I'm opening bugreport again.
Comment 8 leigh scott 2012-09-28 18:14:12 EDT
Does 1.6.1 fix this issue?
Comment 9 Artyom Kunyov 2012-09-29 06:02:19 EDT
Looks like the problem is not in Cinnamon. I just uninstalled Catalyst and installed xorg-x11-video-ati driver, and the problem is gone.

Note You need to log in before you can comment on or make changes to this bug.