Bug 844163 - evince-thumbnailer uses 100% CPU
evince-thumbnailer uses 100% CPU
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libarchive (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
: 818807 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-29 09:06 EDT by cornel panceac
Modified: 2015-03-03 18:05 EST (History)
7 users (show)

See Also:
Fixed In Version: libarchive-3.0.4-2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-28 11:28:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cornel panceac 2012-07-29 09:06:12 EDT
Description of problem:
i've once noticed my CPU temperature was way too high. looking at the processes in top i've noticed evince thumbnailer used almost 100 % of the CPU.

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                                                            
10087 c0rnel    20   0 22616 3736 3176 R 99.7  0.2  15:18.19 evince-thumbnai

 $ ps aux | grep evince
c0rnel   10087 98.1  0.1  22616  3736 ?        R    15:40  15:35 evince-thumbnailer -s 128 file:///home/c0rnel/Downloads/declaratia_392b_2011.xps /tmp/.gnome_desktop_thumbnail.A1P6HW

after killing the process, everything got back to normal. no nautilus windows was opened at that time, and i was in gnome3 fallback mode.

i don't know why evince-thumbnailer was started.
previously, i've opened a Downloads nautilus window. 

possibly unrelated, i often see a crash related to the chormuium package, immediately after logging into gnome fallback session. nobody starts chromium, though. i've also see this (crash) with aother applications, even if afaict nobody starts them. maybe gnome3 does a kind of preloading of things that have shortcuts in the taskbar?

Version-Release number of selected component (if applicable):
$ rpm -q evince
evince-3.4.0-2.fc17.i686


How reproducible:

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Max Alex 2012-09-08 05:19:09 EDT
Same on my laptop running Fedora 17, parsing XPS file.

$ rpm -q evince
evince-3.4.0-2.fc17.x86_64
Comment 2 Morgan Weetman 2013-01-15 17:22:30 EST
I ran across this problem today as well and traced it to an issue in libarchive:

http://code.google.com/p/libarchive/issues/detail?id=226

There is an updated version of libarchive (libarchive-3.0.4-2) in updates-testing that resolved the problem for me:

yum --enablerepo=updates-testing update libarchive

N.B. Updates in the updates-testing repo may not be stable, use at your own risk
Comment 3 Marek Kašík 2013-03-01 09:45:11 EST
Hi Morgan,

thank you for tracing this down to the libarchive. The new version really fixes the problem. I'm reassigning this to libarchive.

Regards

Marek
Comment 4 Tomáš Bžatek 2013-03-28 11:25:44 EDT
*** Bug 818807 has been marked as a duplicate of this bug. ***
Comment 5 Tomáš Bžatek 2013-03-28 11:28:05 EDT
libarchive has been upped to version 3.0.4 which should fix the problem: libarchive-3.0.4-2.fc17

Note You need to log in before you can comment on or make changes to this bug.