Bug 844172 - [Storage][Upgrade Storage Pool] Upgrade ISO domain to v3 doesn't work.
[Storage][Upgrade Storage Pool] Upgrade ISO domain to v3 doesn't work.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.1.0
Assigned To: Daniel Erez
Haim
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-29 10:38 EDT by Leonid Natapov
Modified: 2016-02-10 11:50 EST (History)
12 users (show)

See Also:
Fixed In Version: si13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm and engine logs (688.15 KB, application/octet-stream)
2012-07-29 10:39 EDT, Leonid Natapov
no flags Details
image (147.29 KB, image/png)
2012-07-29 10:40 EDT, Leonid Natapov
no flags Details

  None (edit)
Description Leonid Natapov 2012-07-29 10:38:44 EDT
Scenario:
Data Center 3.0 and Cluster 3.0
NFS Data Domain and NFS ISO Domain.
Everything is up and running.

Changing version of Cluster to 3.1, Changing version of DC to 3.1
Upgrade Storage Pool starts. UpgradeStoragePoolVDSCommand initiated. 
At the and of upgrade process Data Domain successfully upgraded - both the UI and metadata shows Version 3. ISO domain still displayed as V1 in the UI but when clicking on "edit" you see V3 (very weird - see attached picture). 
The metadata file of ISO domain shows version=0.
When creating NFS ISO Domain in datacenter 3.1 ,the metadata shows version=3

Here is the metadata of ISO domain after upgrade:
--------------------------------------------------

CLASS=Iso
DESCRIPTION=ISO
IOOPTIMEOUTSEC=1
LEASERETRIES=3
LEASETIMESEC=5
LOCKPOLICY=
LOCKRENEWALINTERVALSEC=5
MASTER_VERSION=0
POOL_UUID=5fa3f778-f58a-47f2-94cd-19eba75ab8a5
REMOTE_PATH=orion.qa.lab.tlv.redhat.com:/export/lesik
ROLE=Regular
SDUUID=6df03a89-5428-4a25-a509-6a0a67763f93
TYPE=NFS
VERSION=0
_SHA_CKSUM=46592b3f8a1afd941bc8f3ff1ef3214d830e93fa


Here is the metadata of the same ISO Domain from DC 3.1
--------------------------------------------------------
[root@purple-vds2 dom_md]# cat metadata 
CLASS=Iso
DESCRIPTION=ISO
IOOPTIMEOUTSEC=1
LEASERETRIES=3
LEASETIMESEC=5
LOCKPOLICY=
LOCKRENEWALINTERVALSEC=5
MASTER_VERSION=0
POOL_UUID=5fa3f778-f58a-47f2-94cd-19eba75ab8a5
REMOTE_PATH=orion.qa.lab.tlv.redhat.com:/export/lesik
ROLE=Regular
SDUUID=5c83d120-6894-471f-99da-eacfa45f11f2
TYPE=NFS
VERSION=3
_SHA_CKSUM=9ed3e572bf172c072db4bb1459dae30bdeda8a4b

engine log and vdsm log attached.
Comment 1 Leonid Natapov 2012-07-29 10:39:44 EDT
Created attachment 601038 [details]
vdsm and engine logs
Comment 2 Leonid Natapov 2012-07-29 10:40:07 EDT
Created attachment 601039 [details]
image
Comment 3 Itamar Heim 2012-07-29 12:22:52 EDT
why are we upgrading iso domains? shouldn't they stay version 1 for old and new ones?
Comment 4 Haim 2012-07-29 12:46:49 EDT
(In reply to comment #3)
> why are we upgrading iso domains? shouldn't they stay version 1 for old and
> new ones?

per Itamar's comment, setting need-info.

Federico - when creating a new ISO domain, the version is set to #3 - question is if its desired behavior, if so, why domain wasn't upgraded, and if its shouldn't, then we should alter UI to show the correct version.
Comment 5 Federico Simoncelli 2012-07-30 10:42:27 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > why are we upgrading iso domains? shouldn't they stay version 1 for old and
> > new ones?
> 
> per Itamar's comment, setting need-info.
> 
> Federico - when creating a new ISO domain, the version is set to #3 -
> question is if its desired behavior, if so, why domain wasn't upgraded, and
> if its shouldn't, then we should alter UI to show the correct version.

Existing ISO and Export domains shouldn't be upgraded to V3 (that's because they're supposed to be moved from one DC to another).

That said, on a 3.1 DC you can create V3 Export/ISO domains.
Ayal suggested that ISO domains should be created only V1 (also on DC 3.1) because they're going to be deprecated anyway.
Comment 6 Daniel Erez 2012-08-05 14:08:50 EDT
fixed by commit 737094cd27afe1a15c30ea69167347938b21b072

On edit, the ISO domain's format version is V1.
Comment 7 Haim 2012-08-06 09:18:58 EDT
verified on si13 - ISO domain wasn't upgraded and presented as V1. meta-data is not changed as well.

Note You need to log in before you can comment on or make changes to this bug.