Bug 844185 - hplip-3.12.6 tools fail to identify USB attached printer
hplip-3.12.6 tools fail to identify USB attached printer
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-29 12:23 EDT by Steve Alexander
Modified: 2012-09-17 07:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 07:38:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -f hp-probe -busb (345.36 KB, text/plain)
2012-07-29 12:23 EDT, Steve Alexander
no flags Details
lsusb, and various /sys/bus/usb values. (4.22 KB, text/plain)
2012-07-29 12:34 EDT, Steve Alexander
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1031419 None None None 2012-07-31 13:21:55 EDT

  None (edit)
Description Steve Alexander 2012-07-29 12:23:43 EDT
Created attachment 601058 [details]
strace -f hp-probe -busb

Description of problem:hplip tools fail to identify USB attached HP k60xi printer.


Version-Release number of selected component (if applicable):
hplip-3.12.6-1.fc17.x86_64

How reproducible:
100%

Steps to Reproduce:
1.hp-probe -busb
2.
3.
  
Actual results:
HP Linux Imaging and Printing System (ver. 3.12.6)
Printer Discovery Utility ver. 4.1

Copyright (c) 2001-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


--------------------
| DEVICE DISCOVERY |
--------------------

warning: No devices found on the 'usb' bus. If this isn't the result you are expecting,
warning: check to make sure your devices are properly connected and powered on.

Done.


Expected results:
...
  Device URI                                   Model              
  -------------------------------------------  -------------------
  hp:/usb/OfficeJet_K60xi?serial=MY12KC609FOH  HP OfficeJet K60xi 

Found 1 printer(s) on the 'usb' bus.
...

Additional info:
hp-setup fails with
  Searching... (bus=usb, search=(None), desc=0)
  error: No devices found on bus: usb

If directed to use USB device 007:002 then hp-setup fails with:
  Found device: hp:/usb/OfficeJet_K60xi?serial=MY12KC609FOH
  \error: Unable to communicate with device (code=12): hpfax:/usb/OfficeJet_K60xi?serial=MY12KC609FOH
  error: Unable to communicate with the device. Please check the device and try again.

Device works as expected under F14.


Result of ,,,,
strace -f hp-probe -busb
... is attached.
Comment 1 Steve Alexander 2012-07-29 12:34:13 EDT
Created attachment 601059 [details]
lsusb, and various /sys/bus/usb values.
Comment 2 Steve Alexander 2012-07-29 15:09:50 EDT
Problem appears with these packages installed ...
hplip-3.12.6-1.fc17.x86_64 
hplip-common-3.12.6-1.fc17.x86_64
hplip-gui-3.12.6-1.fc17.x86_64
hplip-libs-3.12.6-1.fc17.x86_64                     

By manually installing only the following from package
hplip-libs-3.12.4-2.fc17.x86_64.rpm
/usr/lib64/libhpmud.so
/usr/lib64/libhpmud.so.0
/usr/lib64/libhpmud.so.0.0.6
/usr/lib64/python2.7/site-packages/hpmudext.so
the problem disappears. IN this condition hp-probe and normal printing are successful.

It is believed this problem is isolated to changes in /usr/lib64/libhpmud.so.0.0.6 between 3.12.4-2.fc17 and 3.12.6-1.fc17 .
Comment 3 Jiri Popelka 2012-07-30 10:14:48 EDT
Since 3.12.6 hplip has had a support for libusb-1.0.
Diff of io/hpmud/musb.c between 3.12.4 and 3.12.6 shows a huge amount of changes.

So I think the best you can do is to fill a bug at
https://bugs.launchpad.net/hplip/+filebug
and provide all the info you attached to this ticket.
Thanks
Comment 4 Steve Alexander 2012-07-31 12:50:20 EDT
Problem reported upstream.
Comment 5 Steve Alexander 2012-09-14 03:10:44 EDT
Upstream marked this problem https://bugs.launchpad.net/hplip/+bug/1031419
Won't Fix 

You may as well too.
Comment 6 Tim Waugh 2012-09-17 07:38:55 EDT
OK. Looks like that HPLIP's support for that printer is only as-is now.

Note You need to log in before you can comment on or make changes to this bug.