Bug 844187 - Change log rotate command to maintain consistency with other CLI
Change log rotate command to maintain consistency with other CLI
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: logging (Show other bugs)
mainline
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Ric Wheeler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-29 12:54 EDT by Vijay Bellur
Modified: 2015-05-26 08:33 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.6.0beta1
Doc Type: Enhancement
Doc Text:
Feature: Change in the syntax of log rotate command. Previously it was : volume log rotate <volname> [<brick>] Changed to : volume log <volname> rotate [<brick>] Reason: To maintain uniformity with other commands. Uniform syntax: volume <verb|noun> <volname> [<actions>|options] Result (if any): Change in cli syntax for user. NOTE: Old syntax will also work but will be deprecated after one release.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-11 03:23:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijay Bellur 2012-07-29 12:54:35 EDT
Description of problem:

Right now, the syntax of log rotate is as under:

volume log rotate <volname> [<brick>]

All other commands are of the form:

volume <verb|noun> <volname> [<actions>|options]

It would be good to provide the log rotate command also in a similar format and deprecate the current command.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Amar Tumballi 2012-07-30 02:52:00 EDT
this was done because earlier it was thought to be a separate class all together... setting log, searching for log, etc etc.. 

depricating current option, and adding something like below :

'gluster volume log <VOLNAME> rotate [all*|nfs|bricks|shd]'

looks good to me. Any thoughts?
Comment 2 Amar Tumballi 2012-10-22 00:10:12 EDT
any comments on comment #1?
Comment 3 Amar Tumballi 2012-12-24 04:30:21 EST
reducing the priority as its a cosmetic issue.
Comment 4 Raghavendra Talur 2013-02-28 04:22:46 EST
change posted for review: http://review.gluster.org/#change,4594
Comment 5 Anand Avati 2013-04-23 02:44:46 EDT
REVIEW: http://review.gluster.org/4594 (cli: Changed log rotate command format to common format.) posted (#4) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 6 Anand Avati 2013-04-25 02:10:29 EDT
REVIEW: http://review.gluster.org/4594 (cli: Changed log rotate command format to common format.) posted (#5) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 8 Anand Avati 2014-03-06 00:31:00 EST
COMMIT: http://review.gluster.org/4594 committed in master by Anand Avati (avati@redhat.com) 
------
commit a193f2262b93a06bf1a299f423d4ebaaa171a539
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Thu Feb 28 14:41:52 2013 +0530

    cli: Changed log rotate command format to common format.
    
    Problem:
    The syntax of log rotate was
    volume log rotate <volname> [<brick>]
    All other commands are of the form:
    volume <verb|noun> <volname> [<actions>|options]
    
    Solution:
    Changed log rotate command usage to common format.
    Old syntax is also supported, it will be deprecated
    in next release.
    
    Change-Id: Ia6f6665185a1549c6f79ca763599b446f29e2c78
    BUG: 844187
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/4594
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 10 Niels de Vos 2014-09-22 08:31:10 EDT
A beta release for GlusterFS 3.6.0 has been released. Please verify if the release solves this bug report for you. In case the glusterfs-3.6.0beta1 release does not have a resolution for this issue, leave a comment in this bug and move the status to ASSIGNED. If this release fixes the problem for you, leave a note and change the status to VERIFIED.

Packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update (possibly an "updates-testing" repository) infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-September/018836.html
[2] http://supercolony.gluster.org/pipermail/gluster-users/
Comment 11 Niels de Vos 2014-11-11 03:23:17 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.6.1, please reopen this bug report.

glusterfs-3.6.1 has been announced [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-November/019410.html
[2] http://supercolony.gluster.org/mailman/listinfo/gluster-users
Comment 12 Niels de Vos 2015-05-26 08:33:28 EDT
This bug has been CLOSED, and there has not been a response to the requested NEEDINFO in more than 4 weeks. The NEEDINFO flag is now getting cleared so that our Bugzilla household is getting more in order.

Note You need to log in before you can comment on or make changes to this bug.