This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 84421 - /etc/X11/applnk entries don't show up in the kdemenus
/etc/X11/applnk entries don't show up in the kdemenus
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: desktop-file-utils (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Ben Levenson
: Triaged
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2003-02-16 10:02 EST by Gerald Teschl
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-30 12:48:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2003-02-16 10:02:53 EST
Description of problem:
None of the desktop entries in /etc/X11/applnk/Games shows up in
the K-menu under games.


Version-Release number of selected component (if applicable):
kdebase-3.1-6
kdelibs-3.1-4

How reproducible:
100%

Steps to Reproduce:
ls /etc/X11/applnk/Games/
Maelstrom.desktop     xpilot.desktop       xpilots.desktop

    
Actual results:
None of them can be found in the "Games" or "More Games" menu.
Same if you install some third party games which put their
desktop files there.

Expected results:
Maelstrom.,xpilot,xpilots should show up in the games menue

Additional info:
Probably there are other categories affected as well.
Comment 1 Ngo Than 2003-02-16 10:16:08 EST
it's a desktop-file-utils problem. moving it to desktop-file-utils
Comment 2 Havoc Pennington 2003-02-16 11:53:08 EST
The menu items may be in the Other menu.

Should also file bugs against maelstrom and xpilot for having .desktop 
files in the wrong place...
Comment 3 Havoc Pennington 2003-02-18 12:50:59 EST
desktop-file-utils needs to do better making up categories from 
the dir in /etc/X11/applnk
Comment 4 Bill Nottingham 2003-02-19 17:32:57 EST
Maelstrom is fixed. We don't ship xpilot any more.
Comment 5 Gerald Teschl 2003-02-21 05:37:28 EST
Yes, the items are in the "Other" menu.
Comment 6 Gerald Teschl 2003-03-26 08:54:20 EST
Seems to be fine in desktop-file-utils-0.3-5.
Comment 7 Gerald Teschl 2003-03-30 08:47:57 EST
>desktop-file-utils needs to do better making up categories from 
>the dir in /etc/X11/applnk

It seems like this is still not the case: third party files placed into
/etc/X11/applnk/Games don't show up under "Games" but under "Other"
Comment 8 Havoc Pennington 2003-03-30 12:48:09 EST
I know that's not the case, but the bug was that they don't show up at all,
not the Games vs. Other thing.

In the next release the menu subsystem will be totally rewritten anyhow, 
so it the Games vs. Other fix isn't really an issue that needs tracking
I don't think.

Note You need to log in before you can comment on or make changes to this bug.