Bug 844219 - JBoss AS 7 standalone server is not expanded in tree of the GUI if the initial availablity status is 'DOWN'
JBoss AS 7 standalone server is not expanded in tree of the GUI if the initia...
Status: CLOSED DUPLICATE of bug 828329
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: as7-plugin
  Show dependency treegraph
 
Reported: 2012-07-29 23:41 EDT by Lin Gao
Modified: 2012-07-30 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-30 12:47:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lin Gao 2012-07-29 23:41:46 EDT
Description of problem:
The children resources of the top level imported server can not be listed in GUI if the initial availablity status is 'DOWN'.

How reproducible:


Steps to Reproduce:
1. Start a jboss as7 standalone server, which does not install RHQ admin user yet
2. Start the agent which is located at same machine as jboss as7 standalone server
3. Import the discovered jboss as7 standalone server to RHQ
4. The availablity status of jboss as7 standalone server is 'DOWN' now.
5. Schedule an operation of 'Install RHQ user' to the as7 server.
6. Wait until the availablity status is 'UP'.
7. Then the tree in the left panel should be able to be expanded to list all sub resources
8. Click on 'Children resources' in 'Inventory' tab, all sub resources should be listed.
  
Actual results:
1. The tree in the left panel can not be expanded.

2. Nothing is listed in the 'children resources' in 'Inventory' tab.

Expected results:
1. The tree in the left panel can be expanded after a while.

2. All sub resources are listed in the 'children resources' in 'Inventory' tab

Additional info:
Comment 1 Heiko W. Rupp 2012-07-30 11:56:20 EDT
This is clearly an outcome of our current discovery model.
We can unfortunately not run a discovery when the user has invoked the "install RHQ user" operation with success.

So the user has to wait until the next discovery round for the AS7 instance.

This is not an as7 bug per se.
Comment 2 Charles Crouch 2012-07-30 12:47:14 EDT

*** This bug has been marked as a duplicate of bug 828329 ***
Comment 3 Charles Crouch 2012-07-30 12:47:44 EDT
This bug corresponds to the use case here: https://bugzilla.redhat.com/show_bug.cgi?id=828329#c1

Note You need to log in before you can comment on or make changes to this bug.