Bug 844238 - migrate fails with scalable app embedding mysql when RECREATE_HTTPD_PROXY_CART_TYPES is configured
migrate fails with scalable app embedding mysql when RECREATE_HTTPD_PROXY_CAR...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-30 01:13 EDT by Jianwei Hou
Modified: 2015-05-14 22:02 EDT (History)
0 users

See Also:
Fixed In Version: devenv_1922
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 16:42:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jianwei Hou 2012-07-30 01:13:57 EDT
Description of problem:
create scalable applications with mysql embedded, ssh into devenv, upgrade and migrate, when  RECREATE_HTTPD_PROXY_CART_TYPES is configured in /usr/bin/rhc-admin-migrate, the migrate fails due to node execution failure

Version-Release number of selected component (if applicable):
On devenv-stage_226 


How reproducible:
always

Steps to Reproduce:
1.Create a scalable app with mysql embedded
2.ssh into devenv, upgrade devenv to latest
  yum update
3.Run migrate-mongo-2.0.15 before migrate(specially required in sprint 15)
4.Edit /usr/bin/rhc-admin-migrate, set RECREATE_HTTPD_PROXY_CART_TYPES = nil
5.rhc-admin-migrate --version 2.0.15
  
Actual results:
migrate logs:
Failed to migrate with cmd: '/usr/bin/rhc-admin-migrate --rhlogin 'jhou@redhat.com' --migrate-gear 'd46cd5bcfaac40bcbb5dfd906f27fea8' --app-name 'php1' --version '2.0.15'' after 2 tries with exception: Node execution failure (invalid exit code from node).  If the problem persists please contact Red Hat support.

/var/log/mcollective.log has the error messages:
Failed to restart master httpd, please contact support

/etc/init.d/httpd restart
Starting httpd: httpd: Syntax error on line 221 of /etc/httpd/conf/httpd.conf: Syntax error on line 65 of /etc/httpd/conf.d/000000_default.conf: Syntax error on line 4 of /etc/httpd/conf.d/stickshift/6fd037f5970e4d07aedc236db91be1d6_1920mig_6fd037f597.conf: Include directory '/etc/httpd/conf.d/stickshift/6fd037f5970e4d07aedc236db91be1d6_1920mig_6fd037f597' not found

Under /etc/httpd/conf.d/stickshift/ , there is only 6fd037f5970e4d07aedc236db91be1d6_1920mig_6fd037f597.conf, its corresponding directory is missing, failed to recreate the directory when using  RECREATE_HTTPD_PROXY_CART_TYPES

Expected results:
Migrate should run successfully

Additional info:
Comment 1 Dan McPherson 2012-07-30 10:27:55 EDT
There was potentially a few other issues with RECREATE_HTTPD_PROXY_CART_TYPES and we don't really need the function right now.  So I went ahead and removed it.
Comment 2 Jianwei Hou 2012-07-31 01:52:12 EDT
Verified on devevn_1922

Steps:
1.Launch a old instance, currently devenv-stage_226
2.Create applications before upprade
3.Upgrade devenv to latest
  yum update
4.Check /usr/bin/rhc-admin-migrate, RECREATE_HTTPD_PROXY_CART_TYPES option is removed.
5.Run migrate
  rhc-admin-migrate --version 2.0.15

Result:
Command runs successfully without errors.

Note You need to log in before you can comment on or make changes to this bug.