Bug 844239 - [WebTrans] WebUI shows "Save FAILED" on page 2 or later
[WebTrans] WebUI shows "Save FAILED" on page 2 or later
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.7
Unspecified Unspecified
urgent Severity urgent
: ---
: 1.7.1
Assigned To: Patrick Huang
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-30 01:14 EDT by Ding-Yi Chen
Modified: 2012-12-02 22:20 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.7.2-SNAPSHOT (20120809-0001)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-29 18:29:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2012-07-30 01:14:02 EDT
Description of problem:

In workspace, when trying to save as approved/save as fuzzy anything from second page onward, either popup shows "Save FAILED: row XXX" or nothing happens.

There's no guarantee of the translation will be save in the server. The only way to confirm that is to reload the workspace and see.


Version-Release number of selected component (if applicable):
Zanata version 1.7.0 (20120722-2153)

How reproducible:
Always

Steps to Reproduce:
1. Find a multi-page document that no one has worked before.
2. Change to page 2
3. Type something on the row 1, and save as approved.
4. Click on the row 1, save again.
  
Actual results:
On step 3, no saving notification was received.
On step 4, "save failed" was received.

Expected results:
On step 3, saving notification should be received.
On step 4, saving notification should be received.

Additional info:
Workaround: Translators need to reload the document to confirm the translations are saved.
Comment 1 Patrick Huang 2012-07-30 01:18:22 EDT
committed in origin/release:
https://github.com/zanata/zanata/commit/a4a516e605066b6ac5a2df5290063d140d854281
Comment 2 Ding-Yi Chen 2012-08-08 21:44:38 EDT
Tested with 1.8.0-SNAPSHOT (20120809-0024)
1.7.2-SNAPSHOT (20120809-0001)

1.7 Server seems fixed, but error remain for 1.8 servers.
Comment 3 Ding-Yi Chen 2012-09-13 00:47:04 EDT
VERIFIED with Zanata version 1.8.0-SNAPSHOT (20120913-1412).

Apparently solved by the editor rewrite.

Note You need to log in before you can comment on or make changes to this bug.