Bug 844288 - Incorrect value of APN name for Sonera ISP
Summary: Incorrect value of APN name for Sonera ISP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mobile-broadband-provider-info
Version: 6.3
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Jirka Klimes
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-07-30 08:39 UTC by Josef Zimek
Modified: 2018-11-28 19:41 UTC (History)
3 users (show)

Fixed In Version: mobile-broadband-provider-info-1.20100122-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-25 08:55:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0974 normal SHIPPED_LIVE mobile-broadband-provider-info bug fix update 2013-06-25 12:54:16 UTC

Description Josef Zimek 2012-07-30 08:39:31 UTC
Description of problem:

/usr/share/mobile-broadband-provider-info/serviceproviders.xml contains the following stanza:

        <provider>
                <name>Sonera</name>
                <gsm>
                        <network-id mcc="244" mnc="91"/>

                        <apn value="internet.saunalahti">
                                <name>Postpaid (contract)</name>
                                <dns>192.89.123.230</dns>
                                <dns>192.89.123.231</dns>
                        </apn>
                        <apn value="internet">
                                <name>Prepaid (no contract)</name>
                                <dns>192.89.123.230</dns>
                                <dns>192.89.123.231</dns>
                        </apn>

                        <apn value="prointernet">
                                <name>Prointernet (public IP)</name>
                                <dns>192.89.123.230</dns>
                                <dns>192.89.123.231</dns>
                        </apn>
                </gsm>
        </provider>

which is faulty because APN "internet.saunalahti" is for Saunalahti, another ISP.  APN "internet" works for Sonera.  Minor issue, but prevents the Sonera mobile broadband configuration "postpaid (contract") from working at all.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install package mobile-broadband-provider-info
2. /usr/share/mobile-broadband-provider-info/serviceproviders.xml contains invalid data
  
Actual results:
                        <apn value="internet.saunalahti">
                                <name>Postpaid (contract)</name>
                                <dns>192.89.123.230</dns>
                                <dns>192.89.123.231</dns>
                        </apn>
                        <apn value="internet">
                                <name>Prepaid (no contract)</name>
                                <dns>192.89.123.230</dns>
                                <dns>192.89.123.231</dns>
                        </apn>

                        <apn value="prointernet">
                                <name>Prointernet (public IP)</name>
                                <dns>192.89.123.230</dns>
                                <dns>192.89.123.231</dns>
                        </apn>

Expected results:
Section for Sonera ISP will contain only following sections:
                        <apn value="internet">
                                <name>Prepaid (no contract)</name>
                                <dns>192.89.123.230</dns>
                                <dns>192.89.123.231</dns>
                        </apn>

                        <apn value="prointernet">
                                <name>Prointernet (public IP)</name>
                                <dns>192.89.123.230</dns>
                                <dns>192.89.123.231</dns>
                        </apn>


Additional info:
Check if Saunalathi provider has correct value

Comment 5 RHEL Program Management 2012-09-07 05:24:47 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 12 errata-xmlrpc 2013-06-25 08:55:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0974.html


Note You need to log in before you can comment on or make changes to this bug.