Bug 844307 - Why does tomcat6 package needs a gui?
Why does tomcat6 package needs a gui?
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tomcat6 (Show other bugs)
6.3
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: David Knox
tomcat-qe
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-30 05:19 EDT by Fred van Zwieten
Modified: 2015-11-01 19:17 EST (History)
7 users (show)

See Also:
Fixed In Version: tomcat6-6.0.24-41 el_6_6
Doc Type: Enhancement
Doc Text:
Tomcat 6 can now be installed without a GUI. The dependency on redhat-lsb has been removed, and it is now possible to install Tomcat 6 with a reduced number of installed components without a GUI.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-22 03:27:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred van Zwieten 2012-07-30 05:19:38 EDT
Description of problem:
When installing tomcat6 (directly or using groupinstall web-servlet) on a minimal install RHEL6 box I want to pull in 118 packages, mostly because it thinks it needs a gui. Why does tomcat6 needs a gui?

Version-Release number of selected component (if applicable):
tomcat6 v6.0.24-45.el6

How reproducible:
yum groupinstall web-servlet on a minimal install
_or_
yum install tomcat6 on a minimal install

Steps to Reproduce:
1. yum install tomcat6
2.
3.
  
Actual results:
tomcat6 install including a gui

Expected results:
tomcat6 installed without a gui

Additional info:

Here is the yum output:

================================================================================
 Package                   Arch   Version            Repository            Size
================================================================================
Installing:
 tomcat6                   noarch 6.0.24-45.el6      rhel-x86_64-server-6  88 k
Installing for dependencies:
 ORBit2                    x86_64 2.14.17-3.1.el6    rhel-x86_64-server-6 168 k
 alsa-lib                  x86_64 1.0.22-3.el6       rhel-x86_64-server-6 370 k
 at                        x86_64 3.1.10-43.el6_2.1  rhel-x86_64-server-6  60 k
 atk                       x86_64 1.28.0-2.el6       rhel-x86_64-server-6 191 k
 avahi-libs                x86_64 0.6.25-11.el6      rhel-x86_64-server-6  54 k
 axis                      noarch 1.2.1-7.2.el6      rhel-x86_64-server-6 1.5 M
 bc                        x86_64 1.06.95-1.el6      rhel-x86_64-server-6 110 k
 bcel                      x86_64 5.2-7.2.el6        rhel-x86_64-server-6 1.4 M
 cairo                     x86_64 1.8.8-3.1.el6      rhel-x86_64-server-6 309 k
 cdparanoia-libs           x86_64 10.2-5.1.el6       rhel-x86_64-server-6  47 k
 classpathx-jaf            x86_64 1.0-15.4.el6       rhel-x86_64-server-6 100 k
 classpathx-mail           noarch 1.1.1-9.4.el6      rhel-x86_64-server-6 479 k
 cups                      x86_64 1:1.4.2-48.el6     rhel-x86_64-server-6 2.3 M
 cups-libs                 x86_64 1:1.4.2-48.el6     rhel-x86_64-server-6 315 k
 cvs                       x86_64 1.11.23-11.el6_2.1 rhel-x86_64-server-6 712 k
 ecj                       x86_64 1:3.4.2-6.el6      rhel-x86_64-server-6 2.8 M
 ed                        x86_64 1.1-3.3.el6        rhel-x86_64-server-6  72 k
 fontconfig                x86_64 2.8.0-3.el6        rhel-x86_64-server-6 186 k
 foomatic                  x86_64 4.0.4-1.el6_1.1    rhel-x86_64-server-6 251 k
 foomatic-db               noarch 4.0-7.20091126.el6 rhel-x86_64-server-6 980 k
 foomatic-db-filesystem    noarch 4.0-7.20091126.el6 rhel-x86_64-server-6 4.3 k
 foomatic-db-ppds          noarch 4.0-7.20091126.el6 rhel-x86_64-server-6  19 M
 freetype                  x86_64 2.3.11-6.el6_2.9   rhel-x86_64-server-6 359 k
 gettext                   x86_64 0.17-16.el6        rhel-x86_64-server-6 1.8 M
 ghostscript               x86_64 8.70-14.el6        rhel-x86_64-server-6 4.4 M
 ghostscript-fonts         noarch 5.50-23.1.el6      rhel-x86_64-server-6 750 k
 gnutls                    x86_64 2.8.5-4.el6_2.2    rhel-x86_64-server-6 342 k
 gstreamer                 x86_64 0.10.29-1.el6      rhel-x86_64-server-6 764 k
 gstreamer-plugins-base    x86_64 0.10.29-1.el6      rhel-x86_64-server-6 942 k
 gstreamer-tools           x86_64 0.10.29-1.el6      rhel-x86_64-server-6  23 k
 gtk2                      x86_64 2.18.9-10.el6      rhel-x86_64-server-6 3.3 M
 hicolor-icon-theme        noarch 0.11-1.1.el6       rhel-x86_64-server-6  40 k
 iso-codes                 noarch 3.16-2.el6         rhel-x86_64-server-6 2.5 M
 jakarta-commons-collections
                           noarch 3.2.1-3.4.el6      rhel-x86_64-server-6 523 k
 jakarta-commons-daemon    x86_64 1:1.0.1-8.9.el6    rhel-x86_64-server-6  45 k
 jakarta-commons-dbcp      noarch 1.2.1-13.8.el6     rhel-x86_64-server-6 116 k
 jakarta-commons-discovery noarch 1:0.4-5.4.el6      rhel-x86_64-server-6  73 k
 jakarta-commons-httpclient
                           x86_64 1:3.1-0.6.el6      rhel-x86_64-server-6 580 k
 jakarta-commons-logging   noarch 1.0.4-10.el6       rhel-x86_64-server-6  52 k
 jakarta-commons-pool      x86_64 1.3-12.7.el6       rhel-x86_64-server-6 122 k
 jasper-libs               x86_64 1.900.1-15.el6_1.1 rhel-x86_64-server-6 136 k
 java-1.5.0-gcj            x86_64 1.5.0.0-29.1.el6   rhel-x86_64-server-6 146 k
 java_cup                  x86_64 1:0.10k-5.el6      rhel-x86_64-server-6 197 k
 jpackage-utils            noarch 1.7.5-3.12.el6     rhel-x86_64-server-6  59 k
 lcms-libs                 x86_64 1.19-1.el6         rhel-x86_64-server-6 100 k
 libICE                    x86_64 1.0.6-1.el6        rhel-x86_64-server-6  53 k
 libIDL                    x86_64 0.8.13-2.1.el6     rhel-x86_64-server-6  83 k
 libSM                     x86_64 1.1.0-7.1.el6      rhel-x86_64-server-6  26 k
 libX11                    x86_64 1.3-2.el6          rhel-x86_64-server-6 582 k
 libX11-common             noarch 1.3-2.el6          rhel-x86_64-server-6 188 k
 libXext                   x86_64 1.1-3.el6          rhel-x86_64-server-6  33 k
 libXfont                  x86_64 1.4.1-2.el6_1      rhel-x86_64-server-6 128 k
 libXi                     x86_64 1.3-3.el6          rhel-x86_64-server-6  32 k
 libXrandr                 x86_64 1.3.0-4.el6        rhel-x86_64-server-6  30 k
 libXt                     x86_64 1.0.7-1.el6        rhel-x86_64-server-6 174 k
 libXtst                   x86_64 1.0.99.2-3.el6     rhel-x86_64-server-6  22 k
 libXv                     x86_64 1.0.5-1.el6        rhel-x86_64-server-6  21 k
 libXxf86vm                x86_64 1.1.0-1.el6        rhel-x86_64-server-6  18 k
 libart_lgpl               x86_64 2.3.20-5.1.el6     rhel-x86_64-server-6  65 k
 libfontenc                x86_64 1.0.5-2.el6        rhel-x86_64-server-6  24 k
 libgcj                    x86_64 4.4.6-4.el6        rhel-x86_64-server-6  19 M
 libgomp                   x86_64 4.4.6-4.el6        rhel-x86_64-server-6 117 k
 libjpeg                   x86_64 6b-46.el6          rhel-x86_64-server-6 134 k
 libmng                    x86_64 1.0.10-4.1.el6     rhel-x86_64-server-6 164 k
 libogg                    x86_64 2:1.1.4-2.1.el6    rhel-x86_64-server-6  21 k
 liboil                    x86_64 0.3.16-4.1.el6     rhel-x86_64-server-6 122 k
 libtasn1                  x86_64 2.3-3.el6_2.1      rhel-x86_64-server-6 238 k
 libthai                   x86_64 0.1.12-3.el6       rhel-x86_64-server-6 183 k
 libtheora                 x86_64 1:1.1.0-2.el6      rhel-x86_64-server-6 129 k
 libtiff                   x86_64 3.9.4-6.el6_3      rhel-x86_64-server-6 341 k
 libvisual                 x86_64 0.4.0-9.1.el6      rhel-x86_64-server-6 135 k
 libvorbis                 x86_64 1:1.2.3-4.el6_2.1  rhel-x86_64-server-6 168 k
 libxcb                    x86_64 1.5-1.el6          rhel-x86_64-server-6  99 k
 log4j                     x86_64 1.2.14-6.4.el6     rhel-x86_64-server-6 679 k
 mesa-dri-drivers          x86_64 7.11-5.el6         rhel-x86_64-server-6  11 M
 mesa-libGL                x86_64 7.11-5.el6         rhel-x86_64-server-6 145 k
 mesa-libGLU               x86_64 7.11-5.el6         rhel-x86_64-server-6 201 k
 mx4j                      noarch 1:3.0.1-9.13.el6   rhel-x86_64-server-6 1.1 M
 openjpeg-libs             x86_64 1.3-8.el6_3        rhel-x86_64-server-6  59 k
 pango                     x86_64 1.28.1-3.el6_0.5   rhel-x86_64-server-6 351 k
 patch                     x86_64 2.6-6.el6          rhel-x86_64-server-6  91 k
 pax                       x86_64 3.4-10.1.el6       rhel-x86_64-server-6  69 k
 perl-CGI                  x86_64 3.51-127.el6       rhel-x86_64-server-6 207 k
 perl-ExtUtils-MakeMaker   x86_64 6.55-127.el6       rhel-x86_64-server-6 291 k
 perl-ExtUtils-ParseXS     x86_64 1:2.2003.0-127.el6 rhel-x86_64-server-6  43 k
 perl-Test-Harness         x86_64 3.17-127.el6       rhel-x86_64-server-6 230 k
 perl-Test-Simple          x86_64 0.92-127.el6       rhel-x86_64-server-6 110 k
 perl-devel                x86_64 4:5.10.1-127.el6   rhel-x86_64-server-6 421 k
 phonon-backend-gstreamer  x86_64 1:4.6.2-24.el6     rhel-x86_64-server-6 126 k
 pkgconfig                 x86_64 1:0.23-9.1.el6     rhel-x86_64-server-6  70 k
 poppler                   x86_64 0.12.4-3.el6_0.1   rhel-x86_64-server-6 557 k
 poppler-data              noarch 0.4.0-1.el6        rhel-x86_64-server-6 2.2 M
 poppler-utils             x86_64 0.12.4-3.el6_0.1   rhel-x86_64-server-6  73 k
 portreserve               x86_64 0.0.4-9.el6        rhel-x86_64-server-6  23 k
 qt                        x86_64 1:4.6.2-24.el6     rhel-x86_64-server-6 4.0 M
 qt-sqlite                 x86_64 1:4.6.2-24.el6     rhel-x86_64-server-6  51 k
 qt-x11                    x86_64 1:4.6.2-24.el6     rhel-x86_64-server-6  12 M
 qt3                       x86_64 3.3.8b-30.el6      rhel-x86_64-server-6 3.5 M
 redhat-lsb                x86_64 4.0-3.el6          rhel-x86_64-server-6  24 k
 redhat-lsb-graphics       x86_64 4.0-3.el6          rhel-x86_64-server-6  12 k
 redhat-lsb-printing       x86_64 4.0-3.el6          rhel-x86_64-server-6  11 k
 regexp                    x86_64 1.5-4.4.el6        rhel-x86_64-server-6 105 k
 sinjdoc                   x86_64 0.5-9.1.el6        rhel-x86_64-server-6 705 k
 time                      x86_64 1.7-37.1.el6       rhel-x86_64-server-6  26 k
 tmpwatch                  x86_64 2.9.16-4.el6       rhel-x86_64-server-6  31 k
 tomcat6-el-2.1-api        noarch 6.0.24-45.el6      rhel-x86_64-server-6  43 k
 tomcat6-jsp-2.1-api       noarch 6.0.24-45.el6      rhel-x86_64-server-6  80 k
 tomcat6-lib               noarch 6.0.24-45.el6      rhel-x86_64-server-6 2.9 M
 tomcat6-servlet-2.5-api   noarch 6.0.24-45.el6      rhel-x86_64-server-6  94 k
 urw-fonts                 noarch 2.4-10.el6         rhel-x86_64-server-6 3.1 M
 vmware-tools-libraries-x  x86_64 8.6.0-2            vmware-tools-collection
                                                                          5.5 M
 wsdl4j                    noarch 1.5.2-7.8.el6      rhel-x86_64-server-6 157 k
 xml-common                noarch 0.6.3-32.el6       rhel-x86_64-server-6 9.4 k
 xml-commons-apis          x86_64 1.3.04-3.6.el6     rhel-x86_64-server-6 439 k
 xml-commons-resolver      x86_64 1.1-4.18.el6       rhel-x86_64-server-6 145 k
 xorg-x11-font-utils       x86_64 1:7.2-11.el6       rhel-x86_64-server-6  75 k
 zip                       x86_64 3.0-1.el6          rhel-x86_64-server-6 260 k

Transaction Summary
================================================================================
Install     118 Package(s)

Total download size: 122 M
Installed size: 17 M
Comment 2 matthew patton 2012-09-13 17:57:35 EDT
the problem is redhat-lsb has a bogus (or at least questionable) dependency on redhat-lsb-graphics - which as far as I can tell contains just 2 zero-byte files of no purpose but includes a shedload of child-dependencies. This is what sucks in all the other junk.
Comment 3 matthew patton 2012-09-13 18:09:00 EDT
suggest mark as dup of 835919.
Comment 4 matthew patton 2012-09-13 23:10:51 EDT
Unfortunately the Java runtime itself imposes a number of GUI-related dependencies like gtk2 which in turn pulls in pango and a goodly number of libX*. It would be mighty nice if java-1.6.0-openjdk was fixed to ignore all X11 and if someone actually was trying to run a graphical Java application it would fail until such time as a hypothetical 'java-1.6.0-openjdk-gui' package was installed.

The SUN/Oracle JDK installs don't artificially create this problem and which is why 99.5% of the time I refuse to use Redhat's JRE/JVM and Tomcat RPMs because of all the unhelpful and pointless baggage they invoke. If my java application is intended to have a GUI (eg. Oracle's database installer needs X11 libraries), I'll add them myself!
Comment 5 RHEL Product and Program Management 2012-12-14 03:41:14 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 13 errata-xmlrpc 2015-07-22 03:27:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1461.html

Note You need to log in before you can comment on or make changes to this bug.