Bug 844369 - msgids translations are missing for several languages
msgids translations are missing for several languages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Adrian Likins
Entitlement Bugs
: Translation
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-07-30 08:45 EDT by John Sefler
Modified: 2013-01-07 22:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:58:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-07-30 08:45:05 EDT
Description of problem:
Many languages have incomplete translations for new strings to subscription-manager.  Below is a list for many of the missing translations:

LANGs with missing msgids:
es_ES
ja
as
it
ru
zh_TW
de_DE
mr
ko
fr
or
te
zh_CN
hi
kn

Here is a sample of the missing msgids from LANG=as:

Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "Registering with Customer Portal, Subscription Asset Manager, CloudForms System Engine or Candlepin servers can be used to provide your system with updates and allow management through the selected server's interface."
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "Register System"
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "Contain the text"
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "Consumed Subscriptions"
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "Reset to register with Customer Portal."
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "choose_server_label"
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "server_label"
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "I will register with:"
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "Configure Proxy"
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "SKU Text"
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "%s applied"
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "Filter Options"
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "<b>SKU:</b>"
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "Error: --org is only supported with the --list option"
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "The Subscription Management Service you register with will provide your system with updates and allow additional management."
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "Default"
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "default_button"
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "hostname[:port][/prefix]"
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "SKU: \t%s"
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "proxy_button"
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "If required, please configure your proxy before moving forward."
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "server_entry"
Expected 1 occurance (actual='0') of the following msgid in translation file '/usr/share/locale/as/LC_MESSAGES/rhsm.mo': msgid "Filters"


Version-Release number of selected component (if applicable):
[root@jsefler-rhel59 ~]# rpm -q subscription-manager
subscription-manager-1.0.11-1.git.3.b3c4a8b.el5


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
I am using this bugzilla to block automated tests.  Please move bug to MODIFIED once the next round of translations is incorporated into the builds.
Comment 1 RHEL Product and Program Management 2012-07-30 08:48:22 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 John Sefler 2012-08-15 10:07:59 EDT
adding some more langs that are missing translation msgids...
[root@jsefler-59server ~]# rpm -q subscription-manager
subscription-manager-1.0.13-1.git.27.2a76fe7.el5

gu
pt_BR
pa
ml
bn_IN
Comment 3 Adrian Likins 2012-10-05 11:02:22 EDT
All of the po's are at 100% now. That should be 1.0.22
Comment 6 John Sefler 2012-10-18 12:59:56 EDT
(In reply to comment #3)
> All of the po's are at 100% now. That should be 1.0.22
Agreed.

Automated tests for subscription-manager-1.0.23-1.el5 are reporting:
>   Asserted: Exactly 1 occurance of all the expected translation msgids (678) were found in translation file '/usr/share/locale/<LANG>/LC_MESSAGES/rhsm.mo'
>   Test Passed: VerifyTranslationFileContainsAllMsgids_Test([ **Blocked by bugzilla bug 844369, /usr/share/locale/<LANG>/LC_MESSAGES/rhsm.mo])
for each of the 21 translation files. 

Moving to VERIFIED
Comment 8 errata-xmlrpc 2013-01-07 22:58:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.