Bug 844376 - kvm guest of windows2008 using 48vcpu cause the host system hang.
kvm guest of windows2008 using 48vcpu cause the host system hang.
Status: CLOSED DUPLICATE of bug 827031
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.2
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Gleb Natapov
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-30 08:51 EDT by davidyangyi
Modified: 2012-10-03 07:49 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-03 07:49:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
template file (2.08 KB, text/plain)
2012-07-31 02:42 EDT, davidyangyi
no flags Details

  None (edit)
Description davidyangyi 2012-07-30 08:51:10 EDT
Description of problem:
the host has 48core cpu, and I create just one kvm guest of win2008 of 48vcpu.
when vm start, the host cpu idle is 0%, qemu-kvm takes 4800 %CPU and later the host system hang.
and there is nothing in the /var/log/messages

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Miya Chen 2012-07-30 10:30:09 EDT
Should be duplicate to:
https://bugzilla.redhat.com/show_bug.cgi?id=820112
Comment 3 davidyangyi 2012-07-30 19:55:06 EDT
thanks, but I cannot access the url, why ?

"You are not authorized to access bug #820112"

If I don't have the permission, would you please paste the important part of the tips here? thank you very much.
Comment 4 Mike Cao 2012-07-30 22:37:43 EDT
(In reply to comment #3)
> thanks, but I cannot access the url, why ?
> 
> "You are not authorized to access bug #820112"
> 
> If I don't have the permission, would you please paste the important part of
> the tips here? thank you very much.

Is it a AMD host ? If it is ,pls try to append -numa options in qemu-kvm commandline 
eg: <commandline> -numa node,mem=32G,cpus=0,4,8,12,16,20,nodeid=0  -numa node,mem=32G,cpus=24,28,32,36,40,44,nodeid=1 -numa node,mem=32G,cpus=3,7,11,15,19,23,nodeid=2 -numa node,mem=32G,cpus=27,31,35,39,43,47,nodeid=3 -numa node,mem=32G,cpus=2,6,10,14,18,22,nodeid=4 -numa node,mem=32G,cpus=26,30,34,38,42,46,nodeid=5 -numa node,mem=32G,cpus=1,5,9,13,17,21,nod eid=6 -numa node,mem=32G,cpus=25,29,33,37,41,45,nodeid=7
Comment 5 Mike Cao 2012-07-30 23:01:44 EDT
(In reply to comment #3)
> thanks, but I cannot access the url, why ?
> 
> "You are not authorized to access bug #820112"
> 
> If I don't have the permission, would you please paste the important part of
> the tips here? thank you very much.

It is a public bug now ,you can try to visit it again.
Comment 6 davidyangyi 2012-07-31 02:42:44 EDT
Created attachment 601433 [details]
template file
Comment 7 davidyangyi 2012-07-31 02:43:54 EDT
Comment on attachment 601433 [details]
template file

I add numa into my template file, but it's still the same.

top - 14:44:23 up 3 days, 21:20,  2 users,  load average: 28.16, 7.86, 2.74
Tasks: 960 total,   1 running, 959 sleeping,   0 stopped,   0 zombie
Cpu(s):  3.8%us, 96.2%sy,  0.0%ni,  0.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:  132141572k total, 12608292k used, 119533280k free,   153568k buffers
Swap: 134217720k total,        0k used, 134217720k free,  2769336k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                                                                         
60177 qemu      20   0  104g 6.8g 3544 S 4814.3  5.4  43:37.13 qemu-kvm                                                                                      
60347 oneadmin  20   0 23728 2296 1224 S  4.9  0.0   0:00.23 ruby                                                                                            
60349 oneadmin  20   0 13872 1796  836 S  2.0  0.0   0:00.06 top                                                                                             
60247 root      20   0 13860 1836  844 R  1.3  0.0   0:01.11 top                                                                                             
  195 root      20   0     0    0    0 S  1.0  0.0   0:04.42 events/0                                                                                        
 3253 root      20   0  991m  12m 4336 S  0.7  0.0   1:10.23 libvirtd                                                                                        
    1 root      20   0 19404 1500 1192 S  0.0  0.0   0:04.36 init                                                                                            
    2 root      20   0     0    0    0 S  0.0  0.0   0:00.01 kthreadd
Comment 8 Mike Cao 2012-07-31 02:50:26 EDT
(In reply to comment #7)
> Comment on attachment 601433 [details]
> template file
> 
> I add numa into my template file, but it's still the same.
> 
Does it happen during guest boot or after guest login or both ?

Thanks,
Mike
Comment 9 davidyangyi 2012-07-31 02:54:24 EDT
Comment on attachment 601433 [details]
template file

I add numa into my template file, but it's still the same.

top - 14:44:23 up 3 days, 21:20,  2 users,  load average: 28.16, 7.86, 2.74
Tasks: 960 total,   1 running, 959 sleeping,   0 stopped,   0 zombie
Cpu(s):  3.8%us, 96.2%sy,  0.0%ni,  0.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:  132141572k total, 12608292k used, 119533280k free,   153568k buffers
Swap: 134217720k total,        0k used, 134217720k free,  2769336k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                                                                         
60177 qemu      20   0  104g 6.8g 3544 S 4814.3  5.4  43:37.13 qemu-kvm                                                                                      
60347 oneadmin  20   0 23728 2296 1224 S  4.9  0.0   0:00.23 ruby                                                                                            
60349 oneadmin  20   0 13872 1796  836 S  2.0  0.0   0:00.06 top                                                                                             
60247 root      20   0 13860 1836  844 R  1.3  0.0   0:01.11 top                                                                                             
  195 root      20   0     0    0    0 S  1.0  0.0   0:04.42 events/0                                                                                        
 3253 root      20   0  991m  12m 4336 S  0.7  0.0   1:10.23 libvirtd                                                                                        
    1 root      20   0 19404 1500 1192 S  0.0  0.0   0:04.36 init                                                                                            
    2 root      20   0     0    0    0 S  0.0  0.0   0:00.01 kthreadd
Comment 10 davidyangyi 2012-07-31 02:59:06 EDT
Comment on attachment 601433 [details]
template file

I add numa into my template file, but it's still the same.

top - 14:44:23 up 3 days, 21:20,  2 users,  load average: 28.16, 7.86, 2.74
Tasks: 960 total,   1 running, 959 sleeping,   0 stopped,   0 zombie
Cpu(s):  3.8%us, 96.2%sy,  0.0%ni,  0.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:  132141572k total, 12608292k used, 119533280k free,   153568k buffers
Swap: 134217720k total,        0k used, 134217720k free,  2769336k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                                                                         
60177 qemu      20   0  104g 6.8g 3544 S 4814.3  5.4  43:37.13 qemu-kvm                                                                                      
60347 oneadmin  20   0 23728 2296 1224 S  4.9  0.0   0:00.23 ruby                                                                                            
60349 oneadmin  20   0 13872 1796  836 S  2.0  0.0   0:00.06 top                                                                                             
60247 root      20   0 13860 1836  844 R  1.3  0.0   0:01.11 top                                                                                             
  195 root      20   0     0    0    0 S  1.0  0.0   0:04.42 events/0                                                                                        
 3253 root      20   0  991m  12m 4336 S  0.7  0.0   1:10.23 libvirtd                                                                                        
    1 root      20   0 19404 1500 1192 S  0.0  0.0   0:04.36 init                                                                                            
    2 root      20   0     0    0    0 S  0.0  0.0   0:00.01 kthreadd
Comment 11 davidyangyi 2012-07-31 03:22:12 EDT
Comment on attachment 601433 [details]
template file

I add numa into my template file, but it's still the same.

top - 14:44:23 up 3 days, 21:20,  2 users,  load average: 28.16, 7.86, 2.74
Tasks: 960 total,   1 running, 959 sleeping,   0 stopped,   0 zombie
Cpu(s):  3.8%us, 96.2%sy,  0.0%ni,  0.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:  132141572k total, 12608292k used, 119533280k free,   153568k buffers
Swap: 134217720k total,        0k used, 134217720k free,  2769336k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                                                                         
60177 qemu      20   0  104g 6.8g 3544 S 4814.3  5.4  43:37.13 qemu-kvm                                                                                      
60347 oneadmin  20   0 23728 2296 1224 S  4.9  0.0   0:00.23 ruby                                                                                            
60349 oneadmin  20   0 13872 1796  836 S  2.0  0.0   0:00.06 top                                                                                             
60247 root      20   0 13860 1836  844 R  1.3  0.0   0:01.11 top                                                                                             
  195 root      20   0     0    0    0 S  1.0  0.0   0:04.42 events/0                                                                                        
 3253 root      20   0  991m  12m 4336 S  0.7  0.0   1:10.23 libvirtd                                                                                        
    1 root      20   0 19404 1500 1192 S  0.0  0.0   0:04.36 init                                                                                            
    2 root      20   0     0    0    0 S  0.0  0.0   0:00.01 kthreadd
Comment 12 Ademar Reis 2012-08-16 18:29:16 EDT
(In reply to comment #8)
> 
> Does it happen during guest boot or after guest login or both?

Can you also tell us the CPU model? (cat /proc/cpuinfo)

Looks like a duplicate of either bug 844862 or bug 820112.
Comment 13 Gleb Natapov 2012-08-27 09:11:46 EDT
Probably DUP of bug 827031 (host kernel hang part). Retset with the fix (kernel-2.6.32-288.el6 or later)
Comment 14 Karen Noel 2012-10-03 07:49:00 EDT

*** This bug has been marked as a duplicate of bug 827031 ***

Note You need to log in before you can comment on or make changes to this bug.