Bug 844392 - File > Exit menu problem in mc-4.8.4-2.fc17
File > Exit menu problem in mc-4.8.4-2.fc17
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
https://www.midnight-commander.org/ti...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-30 09:15 EDT by Michael Schwendt
Modified: 2013-07-02 19:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-20 13:22:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing MC in gnome-terminal (2.01 MB, image/png)
2012-07-30 09:15 EDT, Michael Schwendt
no flags Details
screenshot showing MC in gnome-terminal (53.47 KB, image/jpeg)
2012-07-31 06:05 EDT, Michael Schwendt
no flags Details

  None (edit)
Description Michael Schwendt 2012-07-30 09:15:46 EDT
Created attachment 601264 [details]
screenshot showing MC in gnome-terminal

This is about the pending test-update mc-4.8.4-2.fc17.x86_64 and my comment in the related bodhi ticket.

NEWS file says:

    * Improve of mouse event handling in dialogs (#2817)

Attached screenshot shows what my MC looks like. One can see how the menu item at the bottom "Exit F10" overlaps with the menu bar item "2 Menu". So, when I choose the menu to exit mc, the User Menu (F2) is opened instead. This smells like it is related to above change in 4.8.4.

My gnome-terminal is customized a bit via GConf, in particular a larger font:

  $ gconftool-2 --set /apps/gnome-terminal/profiles/Default/use_system_font --type bool false
  $ gconftool-2 --set /apps/gnome-terminal/profiles/Default/font --type string 'Liberation Mono Bold 13'

If I resize the gnome-terminal to be larger, the problem is not reproducible.
Comment 1 Michael Schwendt 2012-07-31 06:05:37 EDT
Created attachment 601500 [details]
screenshot showing MC in gnome-terminal

much smaller screenshot file (requested by upstream)
Comment 2 Jindrich Novy 2012-08-09 04:38:10 EDT
https://www.midnight-commander.org/ticket/2817

This seems to be the upstream ticket related to this.
Comment 3 Michael Schwendt 2012-08-09 07:33:35 EDT
Yeah, see "URL" field of this bugzilla ticket. ;)

Upstream would like 2817 to be reopened, but I can't do that as I'm not registered there.
Comment 4 Slava Zanko 2012-08-20 13:22:17 EDT
https://www.midnight-commander.org/ticket/2817#comment:14

Will be fixed in next release (at the first days of September).

Thanks for bugreport.
Comment 5 Fedora Update System 2012-09-11 12:31:59 EDT
mc-4.8.5-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mc-4.8.5-1.fc18
Comment 6 Fedora Update System 2012-09-11 12:37:33 EDT
mc-4.8.5-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mc-4.8.5-1.fc17
Comment 7 Fedora Update System 2012-09-11 12:55:56 EDT
mc-4.8.5-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/mc-4.8.5-1.fc16
Comment 8 Fedora Update System 2012-09-20 16:31:32 EDT
mc-4.8.5-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2012-09-21 19:54:23 EDT
mc-4.8.5-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2012-09-21 20:03:44 EDT
mc-4.8.5-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.