Bug 844422 - The deployment directory for a jboss as 7 standalone server is 'deployments' instead of 'deployment'
The deployment directory for a jboss as 7 standalone server is 'deployments' ...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
JON 3.1.0
All All
high Severity medium
: ---
: JON 3.1.1
Assigned To: Heiko W. Rupp
Mike Foley
:
Depends On: 844217
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-30 10:34 EDT by Heiko W. Rupp
Modified: 2013-09-11 06:58 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 844217
Environment:
Last Closed: 2013-09-11 06:58:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko W. Rupp 2012-07-30 10:34:42 EDT
+++ This bug was initially created as a clone of Bug #844217 +++

Description of problem:
Deploy a bundle with a WAR archive to JBoss AS 7 standalone server leads to wrong directory.


How reproducible:


Steps to Reproduce:
1.Make an Ant bundle with a simple WAR archive within.
2.Update the bundle file to RHQ to create a new bundle.
3.New a group with JBoss AS 7 standalone server
4.Deploy the bundle to the created group.
  
Actual results:
The WAR is deployed correctly at <JBoss Standalone Server>/standalone/deployments/

Expected results:
The WAR is deployed at <JBoss Standalone Server>/standalone/deployment/<Destination Directory>

Additional info:

This should be a typo.

--- Additional comment from hrupp@redhat.com on 2012-07-30 10:24:52 EDT ---

master 264bf23cb1
Comment 1 Stefan Negrea 2012-07-31 11:23:24 EDT
release/jon3.1.x branch commit:

http://git.fedorahosted.org/git?p=rhq/rhq.git;a=commit;h=bb1765a555263daa7a4185461ed3b730b2a5246e
Comment 2 John Sanda 2012-08-02 14:52:01 EDT
JON 3.1.1 ER1 build is available. Moving to ON_QA.

https://brewweb.devel.redhat.com/buildinfo?buildID=226942
Comment 3 Armine Hovsepyan 2012-08-03 11:53:40 EDT
reopened.

EAP6 ER6
Jon-3.1.1-CR1

Deployment is still being done under EAP6/standalone/deployments
Comment 4 Heiko W. Rupp 2012-08-03 12:10:28 EDT
Armine,
is this with a server you had already in inventory or with an as7 server, that you took into inventory after installing the cr1 ?
Comment 5 Armine Hovsepyan 2012-08-03 13:52:40 EDT
Hi Heiko,

It's the old eap, but has been added into inventory after CR1 was installed. shall i install new eap?
Comment 6 Heiko W. Rupp 2012-08-14 17:38:32 EDT
I've verified that it works correctly with freshly imported as7 servers
Now what happens is that servers in inventory have the old bad value set and this does not get overwritten by the update.
Comment 7 Larry O'Leary 2012-08-16 10:28:36 EDT
The value 'deployments' should not be hard-coded as this is a configurable option in EAP 6 and can change. Therefore, it needs to be a trait and re-discovered from time-to-time or obtained through some other method.
Comment 8 Heiko W. Rupp 2012-08-16 17:16:32 EDT
A new implementation using a trait is now pushed to master as 1ace95e

The plugin config 'deployDir' has been removed, so on plugin upgrade users will
get the correct setting.

Todo QA: test deploying a bundle after plugin upgrade to a server that was in
inventory before the upgrade. As well as deploy to a server that is new in inventory after the upgrade.
Comment 9 Heiko W. Rupp 2012-08-16 17:35:40 EDT
release-branch 09ac5f9a4c1d

QA: also check for drift in the deploy dir.
Comment 10 John Sanda 2012-08-22 01:51:09 EDT
Moving to ON_QA. The JON 3.1.1 ER3 build is available at https://brewweb.devel.redhat.com/buildinfo?buildID=230321.
Comment 11 Armine Hovsepyan 2012-08-24 10:06:45 EDT
reopen.

1. Installed JON 3.1.1 ER3 server/agent
2. Installed EAP plugin ER2
3. Inventoried EAP server
4. Deployed bundle
5. Uploaded EAP plugin ER3 jar
6. Updated plugins
7. Deployed bundle  -------> incorrect directory
8. Reloaded EAP 
9. Deployed bundle  -------> incorrect directory
10. Restarted EAP
11. Deployed bundle  -------> incorrect directory

Clean installation worked correctly. Any deploy dir change is being detected and deployment in correct (new) directory is being done.
Comment 12 Heiko W. Rupp 2012-08-28 14:42:43 EDT
Armine, 
in step 7 did you deploy a new bundle version of the bundle you deployed in step 4 or did you deploy a completely new bundle?

Did you check between steps 6 and 7 if/that the trait has been collected and shows the correct value?
Comment 13 Heiko W. Rupp 2012-08-28 15:31:23 EDT
Armine  in step 7,9,11 -- what is the incorrect directory this writes to?
Comment 14 Heiko W. Rupp 2012-08-28 16:23:57 EDT
So I tried the following:

* installed jon 311er3 server/agent, er2 eap7 plugin
* inventoried eap6ga
* deployed a bundle - worked correctly
* updated plugin to er3 version of the plugin
* deployed a bundle - worked correctly
 * trait is also collected with correct value
Comment 15 Armine Hovsepyan 2012-08-29 02:37:48 EDT
Hi Heiko,

Did you do this for a changed deploy dir or it was for deployments dir?

As it says in comment "Clean installation worked correctly. Any deploy dir change is being detected and deployment in correct (new) directory is being done." - deploy dir needs to be changed beforehand.

Regards,
Armine H
Comment 16 Armine Hovsepyan 2012-09-12 14:57:04 EDT
verified!

Thanks heiko.

Note You need to log in before you can comment on or make changes to this bug.