Bug 84444 - gnome terminal & gnome-system-monitor consume memory
gnome terminal & gnome-system-monitor consume memory
Status: CLOSED DUPLICATE of bug 76219
Product: Red Hat Linux
Classification: Retired
Component: gnome-terminal (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-17 06:58 EST by Robin Clark
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:51:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Clark 2003-02-17 06:58:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
I am having problems in runlevel 5 with my terminal window.  I launch 
the 
system monitor application and keep an eye on it as I work in my 
terminal 
window (gnome terminal).  After launching gnome terminal I cd to a 
directory 
where I am working and I bzcat a large tar file.  I can see the gnome 
terminal 
consuming more and more memory.  I issue some commands to make an 
application 
and I can see gnome terminal consuming upwards of 650 MB of memory (I 
have 256 
MB of RAM).  At this point the CPU% for kswapd is above 50% and the 
screen 
becomes unresponsive.  Mouse clicks, keyboard, Ctrl-Alt-F1, F2, F3, F6 
have no 
effect and I have to reboot.

I have installed 8.0 on a new Dell 2350 Dimension system with 1.7 Ghz 
Celeron 
processor.  The system has an Intel integrated 3D AGP graphics card 
(uses an 
845GL chipset) which is not supported by 8.0, so I disabled the 
on-board video 
card in my bios and installed an old S3 Trio 64V+ video card. In the 
video 
configuration I have specified the S3 Trio 64v+ card with 1 MG memory.  
I've 
changed my resolution down to 640X400 and changed colors to 15 bit.  
I've 
tried "setterm -blank 0".

Further investigation determines that
even without a terminal window running, gnome-system-monitor's memory
consumption increases steadily.  Even when I am not doing anything on the
screen
but watching the system monitor application (no mouse movement or keyboard
activity).

I changed to runlevel 3 in order to continue to work in my text-based terminal
and everything I've been doing is working fine there.	I am doing some pretty big
compiles and they are 
running VERY quickly in the text-based terminal.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  reboot
2.  watch system monitor application
3.   reboot
    

Actual Results:  gnome terminal and or gnome-system-monitor consume huge amounts
of memory until system becomes unresponsive

Expected Results:  much productive work

Additional info:
Comment 1 Robin Clark 2003-02-17 07:05:22 EST
The reason that I have submitted this is because redhat support asked me to. See
the service request:

Incident Number: 228269
Customer Name:   ROBIN CLARK
Customer Number: 455699
Date Opened:     Feb 15, 2003 16:29
Date Changed:    Feb 17, 2003 01:04
Red Hat Tech:    Philip

Our latest response:

Re: gnome-terminal

Dear Sir,

I suggest posting a bug report to our bugtracking system in order for 
our 
developers to be informed about this behaviour of the gnome-terminal 
program:

http://bugzilla.redhat.com

We apologize for the inconvenience.

Regards,
Philip Morales

I can't imagine that this is a bug.  I think that it is a problem with my
configuration.  What can I do to obtain more diagnostic information so that I
can fix this problem?  Thank you.
Comment 2 Havoc Pennington 2003-02-17 11:19:44 EST
Try Xft packages at ftp://people.redhat.com/hp/testing/
they should fix the issue.

*** This bug has been marked as a duplicate of 76219 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:51:50 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.