Bug 844469 - yum doesn't respect skip_if_unavailable=1
yum doesn't respect skip_if_unavailable=1
Status: CLOSED DUPLICATE of bug 842031
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-30 14:40 EDT by Jiri Moskovcak
Modified: 2015-02-01 17:55 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 03:54:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Moskovcak 2012-07-30 14:40:06 EDT
Description of problem:
Even if I use skip_if_unavailble=1 in the repo configuration yum fails to work properly when it's not available


Version-Release number of selected component (if applicable):
yum-3.4.3-28.fc17.noarch

How reproducible:
100%

Steps to Reproduce:
1. create a repo with unacessible url
2. yum update

  
Actual results:
[20:28:17 root@localhost ~]# yum update --noplugins
http://download.lab.bos.redhat.com/rel-eng/brew/fedora/17/repodata/repomd.xml: [Errno 14] curl#6 - "Couldn't resolve host"
Trying other mirror.
Error: failure: repodata/repomd.xml from brew: [Errno 256] No more mirrors to try.
[20:28:49 root@localhost ~]# cat /etc/yum.repos.d/brew.repo 
[brew]
name=Brew Buildsystem for Fedora $releasever - $basearch
baseurl=http://download.lab.bos.redhat.com/rel-eng/brew/fedora/$releasever/
enabled=1
gpgcheck=0
skip_if_unavailable=1

Expected results:
Repo skipped

Additional info:
It used to work...
Comment 1 Zdeněk Pavlas 2012-08-01 03:54:07 EDT

*** This bug has been marked as a duplicate of bug 842031 ***

Note You need to log in before you can comment on or make changes to this bug.