Bug 844481 - [abrt] darktable-1.0.4-1.fc17: _dt_sigsegv_handler: Process /usr/bin/darktable was killed by signal 11 (SIGSEGV)
[abrt] darktable-1.0.4-1.fc17: _dt_sigsegv_handler: Process /usr/bin/darktabl...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: darktable (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Edouard Bourguignon
Fedora Extras Quality Assurance
abrt_hash:0a5b55aefe9d61c668a59a1060a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-30 16:37 EDT by christian.kirbach@googlemail.com
Modified: 2012-11-27 13:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-27 13:57:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (41.48 KB, text/plain)
2012-07-30 16:37 EDT, christian.kirbach@googlemail.com
no flags Details
File: maps (51.40 KB, text/plain)
2012-07-30 16:37 EDT, christian.kirbach@googlemail.com
no flags Details
File: dso_list (11.13 KB, text/plain)
2012-07-30 16:37 EDT, christian.kirbach@googlemail.com
no flags Details
File: build_ids (4.36 KB, text/plain)
2012-07-30 16:37 EDT, christian.kirbach@googlemail.com
no flags Details

  None (edit)
Description christian.kirbach@googlemail.com 2012-07-30 16:37:10 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        darktable '/home/nazgul/Dokumente/ebay Verkauf/_DSC9780.NEF'
crash_function: _dt_sigsegv_handler
executable:     /usr/bin/darktable
kernel:         3.4.6-2.fc17.x86_64
pid:            3361
pwd:            /home/nazgul
remote_result:  NOTFOUND
time:           So 29 Jul 2012 15:49:57 CEST
uid:            1000
username:       nazgul

backtrace:      Text file, 42471 bytes
build_ids:      Text file, 4469 bytes
dso_list:       Text file, 11401 bytes
maps:           Text file, 52636 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/nazgul/1

core_backtrace:
:- 0x0 - - -
:65b8c7bca6e481425b196f4d6c9255b086578b7b 0x4e847 - libdarktable.so -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=1
:HOSTNAME=rivendell
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=2d6effe439fddfe49caea96d0000000e-1343564570.271790-1839988952
:CLUTTER_VBLANK=none
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=nazgul
:USERNAME=nazgul
:MAIL=/var/spool/mail/nazgul
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/nazgul/.local/bin:/home/nazgul/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/nazgul
:XMODIFIERS=@im=none
:KDE_IS_PRELINKED=1
:LANG=de_DE.utf8
:GDM_LANG=de_DE.utf8
:KDEDIRS=/usr
:GDMSESSION=gnome
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/nazgul
:SHLVL=1
:LOGNAME=nazgul
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-EBUMJ6iO4T,guid=12276856f56e6a1591c6063600000011
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/nazgul
:DISPLAY=:0.0
:QT_PLUGIN_PATH=/usr/lib64/kde4/plugins:/usr/lib/kde4/plugins
:XAUTHORITY=/var/run/gdm/auth-for-nazgul-biG3qM/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/813,unix/unix:/tmp/.ICE-unix/813
:GNOME_KEYRING_CONTROL=/run/user/nazgul/keyring-0G1mVR
:GPG_AGENT_INFO=/run/user/nazgul/keyring-0G1mVR/gpg:0:1
:SSH_AUTH_SOCK=/run/user/nazgul/keyring-0G1mVR/ssh
:LC_TIME=de_DE.utf8
:LC_NUMERIC=de_DE.utf8
:LC_MONETARY=de_DE.utf8
:LC_MEASUREMENT=de_DE.utf8
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/darktable.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=3361
:DESKTOP_STARTUP_ID=nautilus-3232-rivendell-darktable-1_TIME4564999

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 63196                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       63196                63196                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/nazgul/.xsession-errors
:pos:	37235
:flags:	0102002
:2:/home/nazgul/.xsession-errors
:pos:	37235
:flags:	0102002
:3:/home/nazgul/.config/darktable/library.db
:pos:	2048
:flags:	02100002
:4:pipe:[45911]
:pos:	0
:flags:	00
:5:pipe:[45911]
:pos:	0
:flags:	01
:6:anon_inode:[timerfd]
:pos:	0
:flags:	04002
:7:pipe:[45912]
:pos:	0
:flags:	00
:8:pipe:[45912]
:pos:	0
:flags:	01
:9:anon_inode:[timerfd]
:pos:	0
:flags:	04002
:10:socket:[45913]
:pos:	0
:flags:	02004002
:11:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:12:socket:[46541]
:pos:	0
:flags:	02004002
:13:/home/nazgul/.local/share/gvfs-metadata/home (deleted)
:pos:	0
:flags:	0100000
:14:/home/nazgul/.local/share/gvfs-metadata/home-0c377670.log (deleted)
:pos:	0
:flags:	0100000
:15:socket:[45916]
:pos:	0
:flags:	02004002
:16:anon_inode:inotify
:pos:	0
:flags:	02004000
:17:socket:[48343]
:pos:	0
:flags:	02004002

var_log_messages:
:Jul 29 15:49:57 rivendell kernel: [ 5239.900370] darktable[3361]: segfault at 0 ip           (null) sp 00007fff5ba76de8 error 14 in darktable[400000+2000]
:Jul 29 15:49:58 rivendell abrt[3876]: Saved core dump of pid 3361 (/usr/bin/darktable) to /var/spool/abrt/ccpp-2012-07-29-15:49:57-3361 (172367872 bytes)
Comment 1 christian.kirbach@googlemail.com 2012-07-30 16:37:14 EDT
Created attachment 601337 [details]
File: backtrace
Comment 2 christian.kirbach@googlemail.com 2012-07-30 16:37:16 EDT
Created attachment 601338 [details]
File: maps
Comment 3 christian.kirbach@googlemail.com 2012-07-30 16:37:19 EDT
Created attachment 601339 [details]
File: dso_list
Comment 4 christian.kirbach@googlemail.com 2012-07-30 16:37:21 EDT
Created attachment 601340 [details]
File: build_ids
Comment 5 Edouard Bourguignon 2012-08-02 03:03:35 EDT
Hi Christian,

What were you doing when dt crash? How can I reproduce this bug?
Comment 6 christian.kirbach@googlemail.com 2012-08-08 18:15:37 EDT
I do not know. DT was running in the background at the time of the crash.
Comment 7 Edouard Bourguignon 2012-09-14 11:23:38 EDT
I'm sorry I can't reproduce that bug. Is darktable still crashing? Is it on this particular file .NEF or with any of them?
Comment 8 christian.kirbach@googlemail.com 2012-09-14 19:09:44 EDT
Not lately. As said it was running in the background and not executing any task, if I remember correctly.
Comment 9 Edouard Bourguignon 2012-11-27 13:57:32 EST
Christian, I'm closing this bug now, please fell free to reopen it if problem persists.

fyi, darktable 1.1 is on its way on Fedora 18.

Note You need to log in before you can comment on or make changes to this bug.