Bug 844554 - ovirt-engine service can't be started because of jboss
ovirt-engine service can't be started because of jboss
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-installer (Show other bugs)
3.1 GA
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ofer Schreiber
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-31 00:49 EDT by Royce Lv
Modified: 2012-09-05 11:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-05 11:44:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Royce Lv 2012-07-31 00:49:41 EDT
Description of problem:
with jboss  7.1.1-4.fc17, ovirt-engine start with error:
Caused by: org.jboss.modules.ModuleLoadException: Error loading
    module from
    /usr/share/jboss-as/modules/javax/xml/registry/api/main/module.xml
         at
    org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:292)
         at
    org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:242)
         at
    org.jboss.modules.LocalModuleLoader.parseModuleInfoFile(LocalModuleLoader.java:138)
         at
    org.jboss.modules.LocalModuleLoader.findModule(LocalModuleLoader.java:122)
         at
    org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:275)
         at
    org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:222)
         at
    org.jboss.modules.LocalModuleLoader.preloadModule(LocalModuleLoader.java:94)
         at org.jboss.modules.Module.addExportedPaths(Module.java:977)
         at org.jboss.modules.Module.addPaths(Module.java:883)
         at org.jboss.modules.Module.link(Module.java:1196)
         at org.jboss.modules.Module.relinkIfNecessary(Module.java:1225)
         at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:208)
         at
    org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:70)
    [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
         ... 5 more

    Caused by: javax.xml.stream.XMLStreamException: ParseError at
    [row,col]:[31,55]
    Message: Failed to add resource root 'jboss-jaxr-1.0-api.jar' at
    path 'jboss-jaxr-1.0-api.jar'
         at
    org.jboss.modules.ModuleXmlParser.parseResourceRoot(ModuleXmlParser.java:898)
         at
    org.jboss.modules.ModuleXmlParser.parseResources(ModuleXmlParser.java:854)
         at
    org.jboss.modules.ModuleXmlParser.parseModuleContents(ModuleXmlParser.java:676)
         at
    org.jboss.modules.ModuleXmlParser.parseDocument(ModuleXmlParser.java:548)
         at
    org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:287)

cleaned jboss-as and removed /usr/share/jboss-as, then reinstalled found:
rpm -ql |grep "module.xml"
/usr/share/jboss-as/modules/javax/xml/registry/api/main/module.xml

so downgrade jboss to jboss-as-7.1.0-3.fc17.noarch,the problem disapeared

Version-Release number of selected component (if applicable):
 jboss 7.1.1-4.fc17
ovirt-engine-3.1.0-1.fc17.noarch

How reproducible:


Steps to Reproduce:
1.run engine-setup
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Marek Goldmann 2012-07-31 03:47:39 EDT
Related to bug 842997 and bug 842996. Please see workarounds there. New jboss-as version with fixed symlinks will be pushed out today to updates-testing.
Comment 2 Marek Goldmann 2012-08-02 04:16:45 EDT
New jboss-as package with fix for this issue was submitted as an update to Fedora: https://admin.fedoraproject.org/updates/jboss-as-7.1.1-6.fc17
Comment 3 Marek Goldmann 2012-09-05 10:18:28 EDT
This should be resolved since some time, feel free to close.

Note You need to log in before you can comment on or make changes to this bug.