Bug 84459 - Dont have installer crash if kickstart NFS mount fails
Dont have installer crash if kickstart NFS mount fails
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-17 13:46 EST by Alexandre Oliva
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-15 16:04:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-generated kickstart file, except for [omitted] instead of root and grub passwords (1.26 KB, text/plain)
2003-02-17 13:47 EST, Alexandre Oliva
no flags Details

  None (edit)
Description Alexandre Oliva 2003-02-17 13:46:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030120

Description of problem:
After assuming that a kickstart file I had created by hand had something broken
that caused the installer to crash, I did a non-kickstart install, took the
generated kickstart file (attached) and put it up in the server that serves
kickstart files.  The installer crashed just the same, right after reading the
kickstart file in.

I booted with `linux ks', and vt4 shows it going its IP infromation from the
DHCP server, while vt3 displays the correct location of the ks file.  that's the
last thing in vt3.

vt1 says `install exited abnormally -- received signal 11', and then a shutdown
sequence.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Put this ks file up on an NFS server
2.Boot with `linux ks' (or use the explicit nfs syntax, it doesn't make any
difference)
 

Actual Results:  The installer crashes

Expected Results:  If there's something wrong with the kickstart file, it should
tell me so.  But I don't think that's it.

Additional info:
Comment 1 Alexandre Oliva 2003-02-17 13:47:58 EST
Created attachment 90137 [details]
anaconda-generated kickstart file, except for [omitted] instead of root and grub passwords
Comment 2 Jeremy Katz 2003-02-17 15:26:29 EST
Adding an install source line to this config doesn't cause a crash for me.  Your
encrypted password doesn't happen to contain something that would get mishandled
by popt does it?
Comment 3 Alexandre Oliva 2003-02-17 16:13:47 EST
Problem was that the kickstart NFS server wasn't running nfsd.  Doh!

Still, the error message doesn't quite help one figure out what the problem is :-(

Note You need to log in before you can comment on or make changes to this bug.