This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 844620 - Dell XPS 13: Bluetooth/WiFi Cannot Operate Independently
Dell XPS 13: Bluetooth/WiFi Cannot Operate Independently
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-31 04:32 EDT by Lorenzo Villani
Modified: 2012-11-13 10:04 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-13 10:04:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch from Ubuntu Launchpad. (1.52 KB, patch)
2012-07-31 04:32 EDT, Lorenzo Villani
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 901410 None None None 2012-07-31 04:32:07 EDT

  None (edit)
Description Lorenzo Villani 2012-07-31 04:32:06 EDT
Created attachment 601471 [details]
Proposed patch from Ubuntu Launchpad.

Description of problem:
There's a bug which prevents the Bluetooth and WiFi radio to operate independently of each other. Turning on/off either Bluetooth or WiFi would turn on/off the other interface. This happens when using the keyboard button (Fn+F2) and gnome-shell switches from the Bluetooth and Network applets.


Version-Release number of selected component (if applicable):
3.4.6-3


How reproducible:
Always


Steps to Reproduce:
1. Press Fn+F2 to turn on or off the WiFi radio.
2. Observe that both Bluetooth and WiFi adapters turn on/off.


Alternative Steps to Reproduce:
1. From within gnome-shell turn off Bluetooth from the indicator's menu.
2. Observe that both Bluetooth and WiFi adapters turn on/off.

  
Actual results:
Both Bluetooth and WiFi radios are turned on/off.


Expected results:
WiFi and Bluetooth radios should operate independently of one another.
Comment 1 Lorenzo Villani 2012-07-31 04:42:24 EDT
I re-built a kernel RPM with the above patch and it seems to work so far.
Comment 2 Dave Jones 2012-07-31 10:13:06 EDT
The rfkill code for this driver has been removed entirely upstream.
I think I'll just backport that, which would fix it for other laptops too.
Comment 3 Lorenzo Villani 2012-08-01 16:55:07 EDT
Confirming that an unpatched 3.5.0 kernel† does not exhibit the issue.


† Custom kernel package based on 3.5.0-2.fc17
Comment 4 Josh Boyer 2012-08-01 20:36:50 EDT
F16 should be getting a rebase to 3.5 next week.
Comment 5 Justin M. Forbes 2012-08-24 16:46:40 EDT
So, it is taking a little longer due to an issue seen in F17 with the 3.5 kernels. Once that is fixed, we will be pushing 3.5 to F16. Sorry for the delay, but it is still going to happen.
Comment 6 Dave Jones 2012-10-23 11:25:14 EDT
# Mass update to all open bugs.

Kernel 3.6.2-1.fc16 has just been pushed to updates.
This update is a significant rebase from the previous version.

Please retest with this kernel, and let us know if your problem has been fixed.

In the event that you have upgraded to a newer release and the bug you reported
is still present, please change the version field to the newest release you have
encountered the issue with.  Before doing so, please ensure you are testing the
latest kernel update in that release and attach any new and relevant information
you may have gathered.

If you are not the original bug reporter and you still experience this bug,
please file a new report, as it is possible that you may be seeing a
different problem. 
(Please don't clone this bug, a fresh bug referencing this bug in the comment is sufficient).
Comment 7 Justin M. Forbes 2012-11-13 10:04:55 EST
With no response, we are closing this bug under the assumption that it is no longer an issue. If you still experience this bug, please feel free to reopen the bug report.

Note You need to log in before you can comment on or make changes to this bug.