Bug 844622 - [RHEVM] [Hot Plug NIC] Hotplug NIC not working with rhel 5.8 guest
[RHEVM] [Hot Plug NIC] Hotplug NIC not working with rhel 5.8 guest
Status: CLOSED DUPLICATE of bug 827544
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.3
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Laine Stump
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-31 04:39 EDT by Martin Pavlik
Modified: 2015-04-06 23:09 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-05 19:34:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (45.84 KB, application/x-gzip)
2012-07-31 04:39 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-07-31 04:39:53 EDT
Created attachment 601472 [details]
logs

Description of problem:
NIC cannot be hot plugged back into VM when RHEL 5u8 x64 is used as a guest OS on VM.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: '3.1.0-9.el6ev' 

libvirt-0.9.10-21.el6.x86_64
qemu-img-rhev-0.12.1.2-2.298.el6_3.x86_64
vdsm-4.9.6-24.0.el6_3.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Create VM with RHEL 5u8 x64/Windows XP installed containing 1 NIC (active)
2. Power up the machine (wait until VM status is UP)
3. Virtual Machines -> your machine -> Network Interfaces -> nic1 -> Deactivate
4. Virtual Machines -> your machine -> Network Interfaces -> nic1 -> Activate
  
Actual results:
NIC is not plugged back

Expected results:
NIC should be plugged back properly


Additional info: log files contain problem for rhel 5u8 

Thread-10987::ERROR::2012-07-31 10:23:37,207::libvirtvm::1390::vm.Vm::(hotplugNic) vmId=`e3653dec-f739-41f9-8126-57d2b15b12ef`::Hotplug failed
Traceback (most recent call last):
  File "/usr/share/vdsm/libvirtvm.py", line 1388, in hotplugNic
    self._dom.attachDevice(nicXml)
  File "/usr/share/vdsm/libvirtvm.py", line 491, in f
    ret = attr(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/vdsm/libvirtconnection.py", line 82, in wrapper
    ret = f(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 400, in attachDevice
    if ret == -1: raise libvirtError ('virDomainAttachDevice() failed', dom=self)
libvirtError: internal error unable to execute QEMU command 'device_add': Duplicate ID 'net0' for device
Comment 2 Laine Stump 2012-08-05 19:34:52 EDT
The problem here is in RHEL5's very poor support for PCI hotplug, and is not something fixable by libvirt (or, as I understand it, fixable on the host side at all). See the comments in Bug 827544 for more info.

*** This bug has been marked as a duplicate of bug 827544 ***

Note You need to log in before you can comment on or make changes to this bug.