Bug 844693 - network.service doesn't start
network.service doesn't start
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-31 08:10 EDT by Paul Lange
Modified: 2014-01-21 04:42 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-14 12:37:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Lange 2012-07-31 08:10:19 EDT
Description of problem:
I usually use wired network with my laptop. However wired network is disabled by default, so I enabled the service:
systemctl enable network.service

But it seems that the start of the service fails on every boot.

[[1;31mFAILED[0m] Failed to start LSB: Bring up/down networking.
         See 'systemctl status network.service' for details.


systemctl status network.service output:
network.service - LSB: Bring up/down networking
	  Loaded: loaded (/etc/rc.d/init.d/network)
	  Active: failed (Result: exit-code) since Tue, 31 Jul 2012 13:39:43 +0200; 24min ago
	 Process: 806 ExecStart=/etc/rc.d/init.d/network start (code=exited, status=1/FAILURE)
	  CGroup: name=systemd:/system/network.service

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.


Version-Release number of selected component (if applicable):
systemd-44-17.fc17

How reproducible:
Enable network.service, reboot computer

Actual results:
Service start fails

Expected results:
Service should start

Additional info:
Comment 1 Michal Schmidt 2012-07-31 08:45:18 EDT
(In reply to comment #0)
> Warning: Journal has been rotated since unit was started. Log output is
> incomplete or unavailable.

Can you find any error messages from the network service in the output of "journalctl -a" ? Or in /var/log/messages?

Does the service fail again if you run "systemctl restart network.service"?
Comment 2 Paul Lange 2012-07-31 10:21:27 EDT
[paul@laptop ~]$ sudo journalctl -a | grep network
Jul 31 13:39:42 laptop NetworkManager[700]: ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-Auto_Aquacate ...
Jul 31 13:39:42 laptop NetworkManager[700]: ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-lo ...
Jul 31 13:39:42 laptop NetworkManager[700]: ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-p1p1 ...
Jul 31 13:39:42 laptop NetworkManager[700]: ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-Was_labersch_du?_-automatisch- ...
Jul 31 13:39:43 laptop network[806]: Bringing up loopback interface:  [  OK  ]
Jul 31 13:39:43 laptop network[806]: Bringing up interface Auto_Aquacate:  Error: Connection activation failed: Device not managed by NetworkManager or unavailable
Jul 31 13:39:43 laptop network[806]: [FAILED]
Jul 31 13:39:43 laptop network[806]: Bringing up interface Was_labersch_du?_-automatisch-:  Error: Connection activation failed: Device not managed by NetworkManager or unavailable
Jul 31 13:39:43 laptop network[806]: [FAILED]
Jul 31 13:39:43 laptop systemd[1]: network.service: control process exited, code=exited status=1
Jul 31 13:39:43 laptop systemd[1]: Unit network.service entered failed state.



[paul@laptop ~]$ systemctl restart network.service 
Failed to issue method call: Access denied


[paul@laptop ~]$ sudo systemctl restart network.service 
Job failed. See system journal and 'systemctl status' for details.


[paul@laptop ~]$ systemctl status 
Too few arguments.


[paul@laptop ~]$ systemctl status network.service 
network.service - LSB: Bring up/down networking
	  Loaded: loaded (/etc/rc.d/init.d/network)
	  Active: failed (Result: exit-code) since Tue, 31 Jul 2012 16:20:02 +0200; 18s ago
	 Process: 5160 ExecStart=/etc/rc.d/init.d/network start (code=exited, status=1/FAILURE)
	  CGroup: name=systemd:/system/network.service

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.


[paul@laptop ~]$ sudo journalctl -a | grep network
Jul 31 13:39:42 laptop NetworkManager[700]: ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-Auto_Aquacate ...
Jul 31 13:39:42 laptop NetworkManager[700]: ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-lo ...
Jul 31 13:39:42 laptop NetworkManager[700]: ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-p1p1 ...
Jul 31 13:39:42 laptop NetworkManager[700]: ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-Was_labersch_du?_-automatisch- ...
Jul 31 13:39:43 laptop network[806]: Bringing up loopback interface:  [  OK  ]
Jul 31 13:39:43 laptop network[806]: Bringing up interface Auto_Aquacate:  Error: Connection activation failed: Device not managed by NetworkManager or unavailable
Jul 31 13:39:43 laptop network[806]: [FAILED]
Jul 31 13:39:43 laptop network[806]: Bringing up interface Was_labersch_du?_-automatisch-:  Error: Connection activation failed: Device not managed by NetworkManager or unavailable
Jul 31 13:39:43 laptop network[806]: [FAILED]
Jul 31 13:39:43 laptop systemd[1]: network.service: control process exited, code=exited status=1
Jul 31 13:39:43 laptop systemd[1]: Unit network.service entered failed state.
Jul 31 16:19:55 laptop dbus-daemon[787]: dbus[787]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.124" (uid=1000 pid=5155 comm="systemctl restart network.service ") interface="org.freedesktop.systemd1.Manager" member="RestartUnit" error name="(unset)" requested_reply="0" destination="org.freedesktop.systemd1" (uid=0 pid=1 comm="/usr/lib/systemd/systemd ")
Jul 31 16:19:55 laptop dbus[787]: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.124" (uid=1000 pid=5155 comm="systemctl restart network.service ") interface="org.freedesktop.systemd1.Manager" member="RestartUnit" error name="(unset)" requested_reply="0" destination="org.freedesktop.systemd1" (uid=0 pid=1 comm="/usr/lib/systemd/systemd ")
Jul 31 16:20:02 laptop sudo[5157]: paul : TTY=pts/0 ; PWD=/home/paul ; USER=root ; COMMAND=/bin/systemctl restart network.service
Jul 31 16:20:02 laptop network[5160]: Bringing up loopback interface:  [  OK  ]
Jul 31 16:20:02 laptop network[5160]: Bringing up interface Auto_Aquacate:  Error: Connection activation failed: Device not managed by NetworkManager or unavailable
Jul 31 16:20:02 laptop network[5160]: [FAILED]
Jul 31 16:20:02 laptop network[5160]: Bringing up interface Was_labersch_du?_-automatisch-:  Error: Connection activation failed: Device not managed by NetworkManager or unavailable
Jul 31 16:20:02 laptop network[5160]: [FAILED]
Jul 31 16:20:02 laptop network[5160]: RTNETLINK answers: File exists
Jul 31 16:20:02 laptop network[5160]: RTNETLINK answers: File exists
Jul 31 16:20:02 laptop network[5160]: RTNETLINK answers: File exists
Jul 31 16:20:02 laptop network[5160]: RTNETLINK answers: File exists
Jul 31 16:20:02 laptop network[5160]: RTNETLINK answers: File exists
Jul 31 16:20:02 laptop network[5160]: RTNETLINK answers: File exists
Jul 31 16:20:02 laptop network[5160]: RTNETLINK answers: File exists
Jul 31 16:20:02 laptop network[5160]: RTNETLINK answers: File exists
Jul 31 16:20:02 laptop network[5160]: RTNETLINK answers: File exists
Jul 31 16:20:02 laptop systemd[1]: network.service: control process exited, code=exited status=1
Jul 31 16:20:02 laptop systemd[1]: Unit network.service entered failed state.
Comment 3 Bill Nottingham 2012-07-31 11:06:06 EDT
You have wireless configurations with ONBOOT=yes that it attempts to bring up - they failed.
Comment 4 Paul Lange 2012-07-31 11:32:21 EDT
How can I disable them? I never marked them as ONBOOT or anything!?
Comment 5 Bill Nottingham 2012-07-31 12:37:03 EDT
Change them to ONBOOT=no?
Comment 6 Harald Hoyer 2012-08-01 11:08:52 EDT
(In reply to comment #2)
> Was_labersch_du?_-automatisch-:  Error: Connection activation failed: Device
> not managed by NetworkManager or unavailable

Wie nennsch denn Du Deine Interfäises? :-)
Comment 7 Paul Lange 2012-08-01 11:59:39 EDT
(In reply to comment #6)
> (In reply to comment #2)
> > Was_labersch_du?_-automatisch-:  Error: Connection activation failed: Device
> > not managed by NetworkManager or unavailable
> 
> Wie nennsch denn Du Deine Interfäises? :-)

Studentenwohnheim ;)



Mh, where can I find the config files. Furthermore, isn't it strange that these wifi networks have ONBOOT= true set, and I haven't done this!?
Comment 8 Bill Nottingham 2012-08-01 13:12:38 EDT
/etc/sysconfig/network-scripts
Comment 9 Lennart Poettering 2012-09-14 09:45:41 EDT
Hmm, there's nothing to fix in systemd here is there?
Comment 10 Paul Lange 2012-09-14 10:10:31 EDT
No, you're right Lennart.
Comment 11 Maram 2014-01-18 17:16:34 EST
you will have to just change ONBOOT = "yes" to ONBOOT = "no"
it is in the configuration file: vi /etc/sysconfig/network-scripts/ifcfg-(name of connection)
Comment 12 tts 2014-01-21 04:42:29 EST
(In reply to Maram from comment #11)
> you will have to just change ONBOOT = "yes" to ONBOOT = "no"
> it is in the configuration file: vi
> /etc/sysconfig/network-scripts/ifcfg-(name of connection)

I confirm this solution for Fedora 20.

I trapped into this bug, while installing multiple machines with Vagrant and VirtualBox (provider).

# uname -r
# 3.12.7-300.fc20.x86_64

Note You need to log in before you can comment on or make changes to this bug.