Bug 844710 - salt Requires: python-jinja2which is not available.
salt Requires: python-jinja2which is not available.
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: salt (Show other bugs)
el6
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Clint Savage
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-31 09:14 EDT by Jaroslav Henner
Modified: 2015-09-14 10:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-31 19:16:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Henner 2012-07-31 09:14:56 EDT
Description of problem:

yum install salt-minion produces:

--> Finished Dependency Resolution
Error: Package: salt-0.10.1-1.el6.noarch (epel)
           Requires: python-jinja2


yum search jinja
python-coffin.noarch : Jinja2 adapter for Django
python-jinja.x86_64 : Sandboxed template engine
python-jinja2-26.noarch : General purpose template engine


Version-Release number of selected component (if applicable):
salt-0.10.1-1.el6.noarch

So either the name python-jinja2-26 is wrong, or salt should have that in deps.


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Clint Savage 2012-07-31 19:16:30 EDT
I'm going to guess you are using RHEL6 as this doesn't happen with CentOS or other rebuilds. The problem you are experiencing is because the python-jinja2 package resides in the RHEL Server Optional (v. 6 64-bit x86_64) Channel.

This is not a bug, you just need to enable the optional channel and you'll be good to go.

Cheers,

Clint
Comment 2 Jaroslav Henner 2012-08-01 03:26:13 EDT
OK. Thanks.
Comment 3 pezzxz 2015-09-03 04:57:14 EDT
But this to my knowledge requires subscription what I don't have and will not buy because of this one package. Any other solution?
Comment 4 Clint Savage 2015-09-14 10:55:34 EDT
If you are using RHEL6, you should be using a subscription service. If not, use CentOS. You *can* also use the CentOS repositories with a RHEL system, but it's not recommended.

Cheers,

herlo

Note You need to log in before you can comment on or make changes to this bug.