Bug 844728 - readline/emacs keybindings don't work in mozilla.org nightly Firefox builds
readline/emacs keybindings don't work in mozilla.org nightly Firefox builds
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-31 10:20 EDT by Josh Matthews
Modified: 2012-08-15 09:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-15 09:44:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Matthews 2012-07-31 10:20:17 EDT
Description of problem: In my brand new install of Fedora 17, the emacs keybindings I expect don't work (eg. ctr+a selects all instead of going to the beginning of the line in text fields). Following the steps at http://kb.mozillazine.org/Emacs_Keybindings_%28Firefox%29 doesn't make a difference.


Version-Release number of selected component (if applicable): Nightly build from mozilla.org for 7/28/12


How reproducible: Consistent.


Additional info: I didn't try the official Fedora build long enough to note whether this was a problem there or not. I also haven't tried mozilla.org Aurora/Beta/Release builds.
Comment 1 Jan Horak 2012-08-01 02:43:07 EDT
Please test upstream release build from: 
ftp://ftp.mozilla.org/pub/firefox/releases/14.0.1/
and Fedora package.
We don't support aurora, beta and nightly on fedora. Only released packages. You can report bugs relevant to nightly to https://bugzilla.mozilla.org.
Comment 2 Josh Matthews 2012-08-01 03:46:22 EDT
Martin did specifically request that I file on this bugtracker rather than mozilla's when I emailed him about this.
Comment 3 Josh Matthews 2012-08-01 03:47:29 EDT
That being said, the Fedora package for 14.0.1 displays the same problem.
Comment 4 Jan Horak 2012-08-01 03:51:14 EDT
Oh, sorry about it, I'm a little bit sleepy in the morning and can't read yet.
Comment 5 Martin Stransky 2012-08-15 08:25:55 EDT
https://bugzilla.mozilla.org/show_bug.cgi?id=72352 seems to be related somehow.
Comment 6 Martin Stransky 2012-08-15 08:47:00 EDT
In the meantime this one may help:

http://lwn.net/Articles/447772/
https://addons.mozilla.org/en-US/firefox/addon/firemacs/
Comment 7 Martin Stransky 2012-08-15 09:23:06 EDT
Does the Emacs binding work in any other application? I'm testing it on F15/GTK3 and I'm unable to get it working.
Comment 8 Martin Stransky 2012-08-15 09:36:38 EDT
Ha, it looks like this one makes the trick:

$gsettings set org.gnome.desktop.interface gtk-key-theme "Emacs"
Comment 9 Josh Matthews 2012-08-15 09:42:09 EDT
Agreed! Thank you very much :)

Note You need to log in before you can comment on or make changes to this bug.