This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 844739 - [RHEVM] [backend] [required networks] host is going non-oprational when non-required network that is on a bond goes down
[RHEVM] [backend] [required networks] host is going non-oprational when non-r...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Muli Salem
meital avital
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-31 11:05 EDT by meital avital
Modified: 2016-02-10 14:55 EST (History)
9 users (show)

See Also:
Fixed In Version: si14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:07:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log (4.51 MB, application/octet-stream)
2012-07-31 12:40 EDT, meital avital
no flags Details

  None (edit)
Description meital avital 2012-07-31 11:05:32 EDT
Description of problem:
If non-required network is attached to bond and bonded NICs go down, host is marked as non-operational despite the fact network is non-required.

Version-Release number of selected component (if applicable): 3.1.0-9.el6ev


How reproducible: 100%


Steps to Reproduce:

1.Clusters -> your cluster -> logical networks -> add network -> fill in name -> click OK

2.Clusters -> your cluster -> logical networks -> Assign/UnAssign Networks -> uncheck required on network from step 1 -> click OK

3.Hosts -> your host (with all interfaces up) -> network interfaces -> setup hosts networks -> create bond (mode 1)-> assign network from step 1 to bond

4.ssh to host and put bond interfaces down ((ifdown eth2 & ifdown eth3)or (physically disconnected the cable))

5) host will be marked as non-operational despite network is non-required
  
Actual results:
host goes non-operational when non-required network is down

Expected results:
host does NOT  go non-operational when non-required network is down


Additional info:

Event : Host zeus-vds2 moved to Non-Operational state because interfaces 'eth3, eth1' are down which needed by networks '<UNKNOWN>' in the current cluster

happens only when the interfaces(eth2,eth3) are down
happens only when network from step 1 is assigned to bond
Comment 2 meital avital 2012-07-31 12:40:51 EDT
Created attachment 601548 [details]
engine log
Comment 3 Muli Salem 2012-08-05 07:21:12 EDT
Proposed fix in:

http://gerrit.ovirt.org/#/c/6902/
Comment 4 Muli Salem 2012-08-05 10:39:34 EDT
Fixed in: 99c25d892c7896d2563d8365761d4952d7417f5e.
Comment 5 meital avital 2012-08-19 02:49:33 EDT
Verified in SI14

Note You need to log in before you can comment on or make changes to this bug.