This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 844766 - scl not built with $RPM_OPT_FLAGS, $RPM_LD_FLAGS
scl not built with $RPM_OPT_FLAGS, $RPM_LD_FLAGS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scl-utils (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
: Patch, Regression
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2012-07-31 13:32 EDT by Ville Skyttä
Modified: 2013-07-02 19:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-02 01:00:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fix dependencies in Makefile (930 bytes, patch)
2012-07-31 13:32 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2012-07-31 13:32:56 EDT
Created attachment 601553 [details]
Fix dependencies in Makefile

scl in 20120731-1 is not built with $RPM_OPT_FLAGS:

http://kojipkgs.fedoraproject.org/packages/scl-utils/20120731/1.fc18/data/logs/x86_64/build.log

Well, actually it is, but then "make install" builds it again without them due to broken deps in Makefile. Fix attached.


Another suggested fix that takes care of using $RPM_LD_FLAGS and parallel build:

--- a/scl-utils.spec
+++ b/scl-utils.spec
@@ -26,4 +26,3 @@ Essential RPM build macros for alternative packaging.
 %build
-export CFLAGS="$RPM_OPT_FLAGS"
-make
+make %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_LD_FLAGS"
Comment 1 Jindrich Novy 2012-08-02 00:59:49 EDT
Applied & fixed in rawhide. Thanks!

Note You need to log in before you can comment on or make changes to this bug.