Bug 844767 - [RFE] In Beaker harness add support for manual mutli-host executions
[RFE] In Beaker harness add support for manual mutli-host executions
Status: CLOSED DUPLICATE of bug 633239
Product: Beaker
Classification: Community
Component: beah (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-31 13:32 EDT by Scott Poore
Modified: 2014-08-12 00:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-27 21:42:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Poore 2012-07-31 13:32:58 EDT
A lot of our tests are written in a multi-host fashion using rhts-sync-block and rhts-sync-set to schedule/order commands running across multiple servers.  

When we are writing and testing them, this means we have to manually watch and press enter on the blocks after a set would have run.  Although useful functionality, it would help also if there was a way to automate the "set".  Something that the "block" could see it without having to run the scripts as jobs in beaker.

So, a manual way to automate rhts-sync-block/set functionality outside of a beaker job, (I think), is what I'm talking about.  Or maybe just some functionality to replicate locally on the servers in question the mechanism that provides the rhts-sync function in a job?

A more complicated additional request here might be setting traps so that automated rhts-sync stop when a specific state is seen from a specific host.  That too might be even more useful for troubleshooting larger, more complicated test suites.

Thanks,
Scott
Comment 1 Dan Callaghan 2012-09-27 21:42:46 EDT

*** This bug has been marked as a duplicate of bug 633239 ***

Note You need to log in before you can comment on or make changes to this bug.