Bug 844772 - Ignore all defined environments when running in local mode
Ignore all defined environments when running in local mode
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tycho (Show other bugs)
17
All Linux
high Severity high
: ---
: ---
Assigned To: Roland Grunberg
Fedora Extras Quality Assurance
:
: 837967 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-31 14:14 EDT by Roland Grunberg
Modified: 2012-08-23 19:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-23 19:32:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland Grunberg 2012-07-31 14:14:25 EDT
When a set of environments are defined in a pom, under the target-platform-configuration plugin, Tycho will attempt to resolve dependencies for each of the specified environments. If we're running in local mode, and offline (eg. mvn-rpmbuild), then we should ignore other environments and just build for the running environment.
Comment 1 Fedora Update System 2012-08-01 09:39:19 EDT
tycho-extras-0.15.0-1.fc17, tycho-0.15.0-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-11197/tycho-extras-0.15.0-1.fc17,tycho-0.15.0-3.fc17
Comment 2 Fedora Update System 2012-08-02 07:20:42 EDT
Package tycho-extras-0.15.0-1.fc17, tycho-0.15.0-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tycho-extras-0.15.0-1.fc17 tycho-0.15.0-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11197/tycho-extras-0.15.0-1.fc17,tycho-0.15.0-3.fc17
then log in and leave karma (feedback).
Comment 3 Roland Grunberg 2012-08-10 11:37:20 EDT
The functionality introduced by 8520b94c739bf4815bc39091f0971bb267ba872d (tycho f17 branch) can cause certain builds to fail since certain plugins might require an environment that doesn't match the system's. We have introduced the flag tycho.local.keepTarget which will allow the build to use the target platform environments defined in the poms instead of defaulting to the system's environment.
Comment 4 Roland Grunberg 2012-08-10 16:20:49 EDT
*** Bug 837967 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2012-08-12 22:26:37 EDT
Package tycho-extras-0.15.0-1.fc17, tycho-0.15.0-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tycho-extras-0.15.0-1.fc17 tycho-0.15.0-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11197/tycho-extras-0.15.0-1.fc17,tycho-0.15.0-4.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-08-23 19:32:13 EDT
tycho-extras-0.15.0-1.fc17, tycho-0.15.0-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.