Bug 844852 - lorax dies on an ignored error?
lorax dies on an ignored error?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
17
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-31 23:27 EDT by Endre "Hrebicek" Balint-Nagy
Modified: 2014-09-23 21:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-02 06:59:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the error message (1.10 KB, text/plain)
2012-07-31 23:27 EDT, Endre "Hrebicek" Balint-Nagy
no flags Details

  None (edit)
Description Endre "Hrebicek" Balint-Nagy 2012-07-31 23:27:13 EDT
Created attachment 601643 [details]
the error message

Description of problem:
While creating an RHEL-7 media lorax died on missing /selinux directory.

Version-Release number of selected component (if applicable):
lorax-17.26-1.fc17.x86_64

How reproducible:
every time

Steps to Reproduce:
1. run a coomand like lorax '--product=Red Hat Enterprise Linux' --version=7.0 --release=7.0 --source=file:///mnt/redhat/rel-eng/${LORAX_REPO}/compose/Server/x86_64/os/  --source=file:///root/repo -e $LORAX_EXCLUDE --buildarch=x86_64 '--volid=RHEL-7.0-0.13rcudebug' /tmp/lorax

2. see the attached error
3.
  
Actual results:
no media made.

Expected results:
the missing /selinux MUST be ignored an the media generated.

Additional info:
Comment 1 Martin Gracik 2012-08-01 03:05:49 EDT
This is not because of missing /selinux, that is ignored.

Your problem is this line

return call(["mksquashfs", rootdir, outfile] + compressargs)

Do you have mksquashfs binary?
Comment 2 Endre "Hrebicek" Balint-Nagy 2012-08-01 11:30:53 EDT
I suppose I had mksquashfs - I am running lorax on a test box as I try to avoid any encounter with gnome3 aka "by a click further" - ,the preceding runs were successful, but will recheck anyway. I am using the same f17 repo (internal).
Comment 3 Endre "Hrebicek" Balint-Nagy 2012-08-02 04:47:45 EDT
despite the repo is the same, now no squashfs-tools package was installed.
installed it additionally, and added it to xml too.
(formerly I made 2-3 DVD images, capable to start anaconda, without squashfs-tools installation. Really strange.)
Thanks for helping. The BZ is a NOTABUG of course.

Note You need to log in before you can comment on or make changes to this bug.