Bug 844895 - multiple entries in smb.conf
multiple entries in smb.conf
Status: CLOSED DUPLICATE of bug 852140
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: unclassified (Show other bugs)
2.1
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Raghavendra Talur
surabhi
:
Depends On:
Blocks: 858434
  Show dependency treegraph
 
Reported: 2012-08-01 03:23 EDT by Raghavendra Bhat
Modified: 2013-08-07 10:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 858434 (view as bug list)
Environment:
Last Closed: 2013-08-07 10:49:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra Bhat 2012-08-01 03:23:55 EDT
Description of problem:

In samba configuration file the glusterfs samba export is present multiple times.

this is what /etc/samba/smb.conf on a RHS machine contains.

[gluster-object]
comment=For samba export of volume object
path=/mnt/samba/object
read only=no
guest ok=yes

[gluster-object]
comment=For samba export of volume object
path=/mnt/samba/object
read only=no
guest ok=yes

[gluster-object]
comment=For samba export of volume object
path=/mnt/samba/object
read only=no
guest ok=yes

[gluster-object]
comment=For samba export of volume object
path=/mnt/samba/object
read only=no
guest ok=yes


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 surabhi 2013-08-07 05:16:22 EDT
The issue is still present.

I create a volume and start it , the smb.conf gets the entry for that volume.
Now if I do a force start , smb.conf will have multiple entries for the same volume.
Comment 3 Vivek Agarwal 2013-08-07 10:49:56 EDT

*** This bug has been marked as a duplicate of bug 852140 ***

Note You need to log in before you can comment on or make changes to this bug.