Bug 844945 - ovirt-engine-backend [Quota]: cannot remove a quota while there are vm's with wrong error message [TEXT]
ovirt-engine-backend [Quota]: cannot remove a quota while there are vm's with...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: ofri
Dafna Ron
sla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 06:29 EDT by Dafna Ron
Modified: 2016-02-10 15:20 EST (History)
9 users (show)

See Also:
Fixed In Version: si14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (78.88 KB, application/x-xz)
2012-08-01 06:29 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-08-01 06:29:45 EDT
Created attachment 601703 [details]
log

Description of problem:

I created a quota with a vm underthe quota. I could not delete the quota with the Quota is not valid error message: 

2012-08-01 13:17:33,487 WARN  [org.ovirt.engine.core.bll.RemoveQuotaCommand] (pool-4-thread-47) CanDoAction of action RemoveQuota failed. Reasons:VAR__ACTION__REMOVE,VAR__TYPE__QUOTA,ACTION_TYPE_FAILED_QUOTA_IS_NOT_VALID

Version-Release number of selected component (if applicable):

si12

How reproducible:

100%

Steps to Reproduce:
1. create a quota and create a vm using the quota
2. create a second quota (since we currently cannot remove last quota in single action)
3. select both quota's and remove 
4. remove the vm -> repeat test
  
Actual results:

only the new quota is removed. the quota with the vm using it is not removed and gives "Quota is not valid" error. 

once we remove the vm we are able to remove the quota

Expected results:

if this behaviour is by design we should change the error message

Additional info: full log
Comment 1 Itamar Heim 2012-08-02 03:45:08 EDT
"Cannot remvoe Quota X as it is associated with resources"

(since this is when user is standing on a quota, and can see associated resources in a subtab, i wouldn't bother with listing them in the error message)
Comment 2 ofri 2012-08-07 01:24:06 EDT
Fixed as part of #844652
Comment 3 Dafna Ron 2012-08-16 09:27:53 EDT
verified on si14

Note You need to log in before you can comment on or make changes to this bug.