Bug 844992 - Can't use string ("11") as an ARRAY ref while "strict refs" in use at /usr/bin/TSDBLocalQueue.pl line 184.
Can't use string ("11") as an ARRAY ref while "strict refs" in use at /usr/bi...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
550
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Jan Pazdziora
Ondrej Cienciala
:
Depends On:
Blocks: sat550-lowbug
  Show dependency treegraph
 
Reported: 2012-08-01 08:30 EDT by Jan Hutař
Modified: 2014-06-18 03:01 EDT (History)
3 users (show)

See Also:
Fixed In Version: tsdb-1.27.27-3-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-21 05:34:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2012-08-01 08:30:09 EDT
Description of problem:
I see some reoccurring error messages in TSDBLocalQueue-errors.log.


Version-Release number of selected component (if applicable):
nocpulse-common-2.2.4-1.el5sat
tsdb-1.27.27-2.el5sat


How reproducible:
1 of 1


Steps to Reproduce:
1. I have enabled monitoring and MonitoringScout
2. Created probe suite and 2 probes ("General: Check Nothing" and "Network Services: Ping")
3. Pushed Scout config
4. I have deleted the probes
5. Re-pushed Scout config
6. I have been monitoring logs during this


Actual results:
# tail /var/log/nocpulse/TSDBLocalQueue-errors.log
[...]
2012-08-01 08:26:37  2012-08-01 08:26:37 Starting TSDB local queue daemon
2012-08-01 08:26:37  Can't use string ("13") as an ARRAY ref while "strict refs" in use at /usr/bin/TSDBLocalQueue.pl line 184.
2012-08-01 08:26:37  2012-08-01 08:26:37 Problem scanning directory: Can't use string ("13") as an ARRAY ref while "strict refs" in use at /usr/bin/TSDBLocalQueue.pl line 90.

Message is there 10 times with ~60seconds between each of these 10 pieces.


Expected results:
No such messages in the log.


Additional info:
I have tried to check this on 5.4.1 and besides other errors I have not seen this one, but not saying my reproducer was 100% same.
Comment 1 Jan Pazdziora 2012-08-01 09:22:12 EDT
What does

# locate MethodMaker.pm | xargs rpm -qf

print?
Comment 2 Jan Pazdziora 2012-08-01 09:45:40 EDT
Making bugzilla public.
Comment 3 Jan Pazdziora 2012-08-01 09:52:30 EDT
Fixed in Spacewalk master, 1ccd5bcffce9f43d1fce0a8d00878f25af660dac.

Also two similar changes in d3615b7487e167ef9e6e17a242b1a6cbab6e5dbf.
Comment 5 Jan Pazdziora 2012-08-01 09:57:35 EDT
I believe that this issue is RHEL 5 specific (due to the version of Class::MakeMaker we have there). When trying to determine whether this is a regression, please make sure you are doing it on the same RHEL version where this problem was observed, and also use the same version for verification.

Of course, also verifying that on RHEL 6 the problem is not present with both the original and the fixed package would be good.
Comment 9 Clifford Perry 2012-09-21 05:34:28 EDT
This issue is resolved with the release of RHN Satellite 5.5. 

As of September 20th 2012, RHN Satellite 5.5 has been generally available. 

Release Notes and other 5.5 documentation can be found here:

 https://access.redhat.com/knowledge/docs/Red_Hat_Network_Satellite/

The associated Errata for the 5.5 release are:

5.5 Satellite GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1296.html

5.5 Upgrade Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1298.html

5.5 RHN Proxy GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1297.html

5.5 RHN Tools GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1299.html

Regards,
Clifford
- Engineering Manager, Satellite

Note You need to log in before you can comment on or make changes to this bug.