Bug 84501 - Intellimouse PS/2: slow movement must rerun mouseconfig to speed up
Intellimouse PS/2: slow movement must rerun mouseconfig to speed up
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-mouse (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-17 21:42 EST by Wayne Pilgrim
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-20 12:47:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wayne Pilgrim 2003-02-17 21:42:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I am running Redhat 8 with a Microsoft Intellimouse PS/2.  When I boot the mouse
movement is very slow.  I need to rerun the mouse configuration via the System
Settings/Mouse .  All I have to do is click "OK" in the mouse settings dialog
since Microsoft Intellimouse is already selected.  As soon as I click OK the
speed of the pointer movement increases to what it is supposed to be.  This
happens for all accounts, from a cold boot and whenever a user logs off.  In
every case , the mouse settings dialog fixes the problem but is this very
annoying.  Lucky I know the root password, otherwise a typical user count not
fix the problem.  Other users in the newsgroups have reported a similar problem
but no one has a fix.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Login
2. Or logout and change accounts.
3. Same slow mouse problem
    

Actual Results:  The mouse moves quite slow. (ie: is not very sensitive).  It is
not jerky, etc....just very slow.

Expected Results:  Mouse should move and respond very quickly, as it does after
running mouseconfig.

Additional info:
Comment 1 Brent Fox 2003-02-18 14:15:39 EST
Are you running Gnome?  If so, try changing the settings in the
gnome-mouse-properties dialog.  That should control sensitivity and acceleration.  

Comment 2 Wayne Pilgrim 2003-02-18 20:24:42 EST
Yes, I am using Gnome.  I ran gnome-mouse-properties and both acceleration and
sensitivity are maxed out and the mouse is still slow.  The problem is also
present in KDE thought.  My root account runs KDE and experiences the same
behaviour.
Comment 3 Brent Fox 2003-02-19 11:25:14 EST
Oh, ok.  I think KDE has it's own mouse properties application.  All
redhat-config-mouse does is set up /etc/sysconfig/mouse and /etc/X11/XF86Config,
but that doesn't have anything to do with sensitivity and acceleration.  

You should be able to find the KDE mouse settings in the KDE control center. 
Does that work?
Comment 4 Wayne Pilgrim 2003-02-19 21:01:29 EST
I can go into KDE and adjust the mouse sensitivity higher so my mouse will
operate at a reasonable speed.  However, as soon as a log out and get back to
the graphical login screen(just X running), the mouse is noticeably more
slugish.  If I log into KDE, my settings definitely take effect and the mouse
sensitivity picks up.  However, if I go back into redhat-mouse-config (in KDE or
Gnome) and click OK, my mouse sensitivity still seems to get amplified....it
ends up being too fast if I'm logged into KDE, and to the point of making the
mouse usable if I'm in Gnome.  The short term fix is to use KDE and skip Gnome
but that's limited at best...I like Gnome.  I see what you mean about
sysconfig/mouse and XF86Config not having any sensitivity settings.  I'm still
confused by what's happening.
Comment 5 Brent Fox 2003-02-20 12:47:47 EST
I'm confused too.  I really don't see how running redhat-config-mouse could
affect the sensitivity.  I've never seen that behavior.

I can verify that the desktop-specific mouse settings like sensitivity are not
used during GDM.  But like you said, logging into a desktop should initialize
the settings when the desktop starts up.

I'm not able to reproduce the problem with redhat-config-mouse changing the
mouse settings, so I'm going to close as "worksforme".
Comment 6 Need Real Name 2003-07-30 10:25:10 EDT
Found a possible fix. Edit /etc/X11/XF86Config file (need root privileges for
this). In there should be 2 "InputDevice" sections (at least I have). Both
contain a number of "Option" lines. Add the following line to both:
"Option" "Resolution" "6400"

For example, there are my sections, before and after:

Before:

***
 
Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/psaux"
        Option      "ZAxisMapping" "4 5"
        Option      "Buttons" "5"
        Option      "Emulate3Buttons" "no"
EndSection
 
Section "InputDevice"
 
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
        Identifier  "DevInputMice"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Buttons" "5"
        Option      "Emulate3Buttons" "no"
EndSection
 
***

After:

***

 
Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/psaux"
        Option      "ZAxisMapping" "4 5"
        Option      "Buttons" "5"
        Option      "Emulate3Buttons" "no"
        Option      "Resolution" "6400"
EndSection
 
Section "InputDevice"
 
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
        Identifier  "DevInputMice"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Buttons" "5"
        Option      "Emulate3Buttons" "no"
        Option      "Resolution" "6400"
EndSection
 
***

If the mouse seems too fast, reduce the resolution to a lower number.

My guess is that the resolution parameter defaults to something ridicilously
low, and rhn-config-mouse sets it correctly.

Note You need to log in before you can comment on or make changes to this bug.