Bug 845030 - [engine-core] Error during log command (LunDisk cannot be cast to org.ovirt.engine.core.common.businessentities.DiskImage)
[engine-core] Error during log command (LunDisk cannot be cast to org.ovirt....
Status: CLOSED DUPLICATE of bug 844153
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.1.0
Assigned To: Ayal Baron
Haim
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 10:36 EDT by Gadi Ickowicz
Modified: 2016-02-10 12:17 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-02 06:51:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log file (2.40 MB, application/octet-stream)
2012-08-01 10:36 EDT, Gadi Ickowicz
no flags Details

  None (edit)
Description Gadi Ickowicz 2012-08-01 10:36:55 EDT
Created attachment 601757 [details]
engine log file

Description of problem:
The follwing error appeared in the ovirt logs:

Error during log command: org.ovirt.engine.core.bll.UpdateVmDiskCommand. Exception java.lang.ClassCastException: org.ovirt.engine.core.common.businessentities.LunDisk cannot be cast to org.ovirt.engine.core.common.businessentities.DiskImage: java.lang.ClassCastException: org.ovirt.engine.core.common.businessentities.LunDisk cannot be cast to org.ovirt.engine.core.common.businessentities.DiskImage


Version-Release number of selected component (if applicable):
rhevm-3.1.0-9.el6ev.noarch SI12

How reproducible:
Not sure how this happened

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

lines from log:
2012-07-31 15:54:02,994 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DestroyVDSCommand] (QuartzScheduler_Worker-81) START, DestroyVDSCommand(vdsId = d2fe6f12-d94a-11e1-9e77-001a4a169705, vmId=5239fb07-a5b0-4372-a4cd-42b8283e457e, force=false, secondsToWait=0, gracefully=false), log id: 40bb644e
2012-07-31 15:54:03,012 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DestroyVDSCommand] (QuartzScheduler_Worker-81) FINISH, DestroyVDSCommand, log id: 40bb644e
2012-07-31 15:54:03,086 INFO  [org.ovirt.engine.core.vdsbroker.VdsUpdateRunTimeInfo] (QuartzScheduler_Worker-81) vm rhel-scsi running in db and not running in vds - add to rerun treatment. vds cougar04
2012-07-31 15:55:00,000 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-51) Checking autorecoverable hosts
2012-07-31 15:55:00,015 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-51) Autorecovering 0 hosts
2012-07-31 15:55:00,015 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-51) Checking autorecoverable hosts done
2012-07-31 15:55:00,015 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-51) Checking autorecoverable storage domains
2012-07-31 15:55:00,016 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-51) Autorecovering 0 storage domains
2012-07-31 15:55:00,016 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-51) Checking autorecoverable storage domains done
2012-07-31 15:59:53,441 INFO  [org.ovirt.engine.core.bll.UpdateVmDiskCommand] (ajp-/127.0.0.1:8009-1) Lock Acquired to object EngineLock [exclusiveLocks= , sharedLocks= key: 5239fb07-a5b0-4372-a4cd-42b8283e457e value: VM
]
2012-07-31 15:59:53,441 INFO  [org.ovirt.engine.core.bll.UpdateVmDiskCommand] (pool-4-thread-49) [24bcd81b] Running command: UpdateVmDiskCommand internal: false. Entities affected :  ID: a1163279-d9e2-474b-b5a6-0f880c8ac44c Type: Disk
2012-07-31 15:59:53,477 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.UpdateVMVDSCommand] (pool-4-thread-49) [24bcd81b] START, UpdateVMVDSCommand(storagePoolId = ce097685-6b9d-408f-b573-ec516667c2a1, ignoreFailoverLimit = false, compatabilityVersion = null, storageDomainId = 00000000-0000-0000-0000-000000000000, infoDictionary.size = 1), log id: 53d5cc24
2012-07-31 15:59:53,505 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.UpdateVMVDSCommand] (pool-4-thread-49) [24bcd81b] FINISH, UpdateVMVDSCommand, log id: 53d5cc24
2012-07-31 15:59:53,528 INFO  [org.ovirt.engine.core.bll.UpdateVmDiskCommand] (pool-4-thread-49) [24bcd81b] Lock freed to object EngineLock [exclusiveLocks= , sharedLocks= key: 5239fb07-a5b0-4372-a4cd-42b8283e457e value: VM
]
2012-07-31 15:59:53,528 WARN  [org.ovirt.engine.core.compat.backendcompat.PropertyInfo] (pool-4-thread-49) Unable to get value of property: storagePool for class org.ovirt.engine.core.bll.UpdateVmDiskCommand
2012-07-31 15:59:53,529 WARN  [org.ovirt.engine.core.compat.backendcompat.PropertyInfo] (pool-4-thread-49) Unable to get value of property: storagePoolId for class org.ovirt.engine.core.bll.UpdateVmDiskCommand
2012-07-31 15:59:53,530 WARN  [org.ovirt.engine.core.compat.backendcompat.PropertyInfo] (pool-4-thread-49) Unable to get value of property: storagePoolName for class org.ovirt.engine.core.bll.UpdateVmDiskCommand
2012-07-31 15:59:53,532 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogableBase] (pool-4-thread-49) [24bcd81b] Error during log command: org.ovirt.engine.core.bll.UpdateVmDiskCommand. Exception java.lang.ClassCastException: org.ovirt.engine.core.common.businessentities.LunDisk cannot be cast to org.ovirt.engine.core.common.businessentities.DiskImage: java.lang.ClassCastException: org.ovirt.engine.core.common.businessentities.LunDisk cannot be cast to org.ovirt.engine.core.common.businessentities.DiskImage
        at org.ovirt.engine.core.bll.UpdateVmDiskCommand.getStoragePoolId(UpdateVmDiskCommand.java:55) [engine-bll.jar:]
        at org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector.log(AuditLogDirector.java:747) [engine-dal.jar:]
        at org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector.log(AuditLogDirector.java:724) [engine-dal.jar:]
        at org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector.log(AuditLogDirector.java:720) [engine-dal.jar:]
        at org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogableBase.log(AuditLogableBase.java:393) [engine-dal.jar:]
        at org.ovirt.engine.core.bll.CommandBase.LogCommand(CommandBase.java:963) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.Execute(CommandBase.java:926) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.ExecuteAction(CommandBase.java:276) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.MultipleActionsRunner.executeValidatedCommands(MultipleActionsRunner.java:182) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.MultipleActionsRunner.RunCommands(MultipleActionsRunner.java:162) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.MultipleActionsRunner$1.run(MultipleActionsRunner.java:84) [engine-bll.jar:]
        at org.ovirt.engine.core.utils.threadpool.ThreadPoolUtil$InternalWrapperRunnable.run(ThreadPoolUtil.java:64) [engine-utils.jar:]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) [rt.jar:1.7.0_05-icedtea]
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334) [rt.jar:1.7.0_05-icedtea]
        at java.util.concurrent.FutureTask.run(FutureTask.java:166) [rt.jar:1.7.0_05-icedtea]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_05-icedtea]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_05-icedtea]
        at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_05-icedtea]
Comment 1 Yaniv Kaul 2012-08-01 14:05:44 EDT
Duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=844153 ?
Comment 2 Itamar Heim 2012-08-02 06:51:45 EDT

*** This bug has been marked as a duplicate of bug 844153 ***

Note You need to log in before you can comment on or make changes to this bug.