Bug 845047 - irssi - Inconsistency between manual page and help message (option --usage not working)
Summary: irssi - Inconsistency between manual page and help message (option --usage no...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: irssi
Version: 6.3
Hardware: All
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Filip Holec
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-08-01 15:19 UTC by Filip Holec
Modified: 2016-04-18 10:21 UTC (History)
1 user (show)

Fixed In Version: irssi-0.8.15-5.el6
Doc Type: Bug Fix
Doc Text:
Previously in the man page there was documented non implemented option --usage. This was leftover from old irssi version when popt was used. Later the code switched to glib's goption, but the documentation wasn't change. The documentation was updated and it is now correct.
Clone Of:
Environment:
Last Closed: 2012-08-15 16:06:07 UTC


Attachments (Terms of Use)
Proposed fix (451 bytes, patch)
2012-08-03 14:52 UTC, Jaroslav Škarvada
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1171 normal SHIPPED_LIVE irssi bug fix update 2012-08-15 20:05:30 UTC

Description Filip Holec 2012-08-01 15:19:42 UTC
Description of problem:
In man page of irssi, it is shown that option --usage is a valid option. However, help message doesn't list this option as a valid option. Running irssi with option --usage will show error message.

Version-Release number of selected component (if applicable):
irssi-0.8.15-3.el6.x86_64

How reproducible: Always

Steps to Reproduce:
1. Check man pages (option --usage is a valid option)
2. Check help message (option --usage is not a valid option)
3. Run 'irssi --usage'
  
Actual results:
Unknown option --usage
Run 'irssi --help' to see a full list of available command line options.

Expected results:
Display brief usage message or remove option --usage from manual page.

Additional info:

Comment 3 Jaroslav Škarvada 2012-08-03 14:52:09 UTC
Created attachment 602146 [details]
Proposed fix

Leftover from popt, removing from man.

Fix sent upstream.

Comment 4 Jaroslav Škarvada 2012-08-03 15:11:16 UTC
Upstream ticket:
http://bugs.irssi.org/index.php?do=details&task_id=873&project=5&pagenum=12

Comment 5 Jaroslav Škarvada 2012-08-03 15:11:17 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously in the man page there was documented non implemented option --usage. This was leftover from old irssi version when popt was used. Later the code switched to glib's goption, but the documentation wasn't change. The documentation was updated and it is now correct.

Comment 9 errata-xmlrpc 2012-08-15 16:06:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1171.html


Note You need to log in before you can comment on or make changes to this bug.