Bug 845051 - 500 OOPS: vsf_sysutil_bind while passive port occupied
500 OOPS: vsf_sysutil_bind while passive port occupied
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: vsftpd (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Jiri Skala
Dalibor Pospíšil
:
: 873977 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 11:21 EDT by Dalibor Pospíšil
Modified: 2014-11-09 17:35 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 02:04:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The patch backports passive mode handling from rhel-6 (17.27 KB, patch)
2012-09-17 11:38 EDT, Jiri Skala
no flags Details | Diff

  None (edit)
Description Dalibor Pospíšil 2012-08-01 11:21:54 EDT
Description of problem:
500 OOPS: vsf_sysutil_bind while passive port occupied by other app like nc

Version-Release number of selected component (if applicable):
vsftpd-2.0.5-24.el5_8.1

How reproducible:
always

Steps to Reproduce:
1. run /CoreOS/vsftpd/Sanity/500-OOPS-vsf_sysutil_bind-while-passive-port-occupied
2.
3.
  
Actual results:
ftp> ls
500 OOPS: vsf_sysutil_bind
Passive mode refused.  Turning off passive mode.
500 OOPS: child died
421 Service not available, remote server has closed connection
ftp> bye


Expected results:
ftp> ls
227 Entering Passive Mode (127,0,0,1,19,146)
150 Here comes the directory listing.
-rw-r--r--    1 0        0              13 Aug 01 13:21 testfile
226 Directory send OK.


Additional info:
If allowed passive ports are free this issue does not appear.
It also appears in multi-host scenario.
Comment 3 Jiri Skala 2012-09-17 11:38:11 EDT
Created attachment 613715 [details]
The patch backports passive mode handling from rhel-6
Comment 4 RHEL Product and Program Management 2012-09-25 05:08:31 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 14 Dalibor Pospíšil 2012-10-10 11:11:44 EDT
The reproducer is not accurate it touches probability limits and so the solution could be done by some RFE on this behaviour. Thus the bug is considered as verified as sanity only.
Comment 15 Keigo Noha 2012-11-13 02:32:40 EST
*** Bug 873977 has been marked as a duplicate of this bug. ***
Comment 20 errata-xmlrpc 2013-01-08 02:04:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0025.html

Note You need to log in before you can comment on or make changes to this bug.