Bug 845058 - CPU loop in cinnamon 2D
CPU loop in cinnamon 2D
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: cinnamon (Show other bugs)
17
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 11:37 EDT by Stuart D Gathman
Modified: 2012-08-16 14:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 848896 (view as bug list)
Environment:
Last Closed: 2012-08-15 01:04:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stuart D Gathman 2012-08-01 11:37:57 EDT
Description of problem:
cinnamon process uses 100% CPU while desktop is idle

Version-Release number of selected component (if applicable):
cinnamon-1.5.1-1.fc17.i686

How reproducible:
always

Steps to Reproduce:
1. Log in with Cinnamon-2D desktop on 82865G 
2. do nothing else
3.
  
Actual results:
cinnamon process in a run loop, but other wise works correctly (overview works, etc).

Expected results:
Minimal CPU use when idle

Additional info:
gnome-shell does not work on 82865G - reverting to fallback, and I like cinnamon layout better anyway.  I haven't tried cinnamon 3D - I assumed it was a lost cause on 82865G.
Comment 1 Stuart D Gathman 2012-08-01 11:43:18 EDT
I guess you have to load top in a terminal or gkrellm to see the CPU usage.  *Then* do nothing.
Comment 2 Stuart D Gathman 2012-08-01 11:47:40 EDT
Tried cinnamon 3D.  This reverts to gnome-fallback.
Comment 3 Wade Mealing 2012-08-15 00:40:20 EDT
I'm getting the same thing, very easy to reproduce even with the latest 

cinnamon-1.5.2-2.fc17.x86_64

lspci:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

I noticed both xorg and cinnamon both trying to consume all available CPU resources.  

Tried restarting, removing $HOME/.config at the moment the desktop is not usable.
Comment 4 leigh scott 2012-08-15 01:03:19 EDT
(In reply to comment #3)
> I'm getting the same thing, very easy to reproduce even with the latest 

I can't reproduce it here as I have no intel hardware available to test.
You should report it upstream if you want it fixed as it's unlikely to be resolved by me.


https://github.com/linuxmint/Cinnamon/issues
Comment 5 Stuart D Gathman 2012-08-16 14:03:31 EDT
You don't need Intel hardware.  Happens on ATI also.  Just run Cinnamon2D instead of regular cinnamon.  It's just that when 3D actually works, you don't need the 2D version.  But the 2D version is unusable at the moment.  I've changed the title.  I'll try to test on a few more video cards.
Comment 6 Stuart D Gathman 2012-08-16 14:09:36 EDT
Here is lspci from an ATI system where cinnamon2D loops:

01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS482 [Radeon Xpress 200M] [1002:5975] (prog-if 00 [VGA controller])
	Subsystem: Dell Device [1028:01f5]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 66 (2000ns min), Cache Line Size: 32 bytes
	Interrupt: pin A routed to IRQ 17
	Region 0: Memory at c8000000 (32-bit, prefetchable) [size=128M]
	Region 1: I/O ports at 9000 [size=256]
	Region 2: Memory at c0100000 (32-bit, non-prefetchable) [size=64K]
	[virtual] Expansion ROM at c0120000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: radeon
Comment 7 Stuart D Gathman 2012-08-16 14:12:57 EDT
Not sure if anyone sees updates here since it was (prematurely) closed, so I cloned it to bug#848896

Note You need to log in before you can comment on or make changes to this bug.