Bug 845088 - EWS Doesn't show all mail messages
EWS Doesn't show all mail messages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: evolution-ews (Show other bugs)
17
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 13:41 EDT by Craig Lanning
Modified: 2012-09-03 18:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-03 18:55:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Craig Lanning 2012-08-01 13:41:03 EDT
Description of problem:

I have a corproate email account on office365 that I can access via EWS or IMAP.  I prefer to use EWS since that gives better integration between the email and the calendar, but I have noticed that sometimes EWS doesn't show all of the messages.  If I disable my EWS connection and use the IMAP connection instead, I sometimes see additional messages.


Version-Release number of selected component (if applicable):
evolution v3.4.3-2.fc17.x86_64
evolution-ews v3.4.3-1.fc17.x86_64

How reproducible:
It seems to be intermittant.  Not all messages are lost.


Steps to Reproduce:
1. Use EWS to access mail for a while
2. disable EWS, enable IMAP
3. notice a few messages which have never been seen before
  
Actual results:


Expected results:
EWS should provide access to all messages.


Additional info:
Comment 1 Milan Crha 2012-08-02 03:13:02 EDT
Thanks for a bug report. EWS depends on proper synchronization as reported by the server, which basically means it shows what server returns as new/modified/deleted since the last check, thus I think evolution knows about the messages, but hides them from the UI for some reason. The reason can be that the messages are recognized as deleted or junk, which are not shown in the UI by default.

Another option would be that EWS stored its ChangeKey even when not done with fetching of changes, thus it could be left in an invalid state - like if it crashed during message downloading, before it was able to update its internals to reflect new change state. Do you think this could happen to you?
Comment 2 Craig Lanning 2012-08-02 08:14:09 EDT
I haven't seen Evolution crash, but I noticed that evolution seems to have a lot of trouble talking to the server.  It will regularly have trouble refreshing some of the folders.  Maybe that is similar to what you are talking about.  I have also noticed that IMAP sometimes has trouble refreshing folders so some of the issue may be with the Microsoft server.

Is there anything I could do to collect more info for you?
Comment 3 Milan Crha 2012-08-03 07:08:23 EDT
Thanks for the update. I would start with a test package of evolution-ews from bug #844298 comment #3, which contains quite many fixes, between which is also better interoperability with unreliable servers.
Comment 4 Milan Crha 2012-08-03 07:12:18 EDT
Oops, and also clear local cache, to get to correct state. The cache is stored in ~/.cache/evolution/mail/<ews-account-uid>. You can remove whole folder, as it's just local copy of the server information, only make sure evolution will not be running, same as other evolution-related processes (ps ax | grep evolution).
Comment 5 Craig Lanning 2012-08-03 10:32:47 EDT
I installed the update and flushed the cache.  Now I'll run it for a while and see how it does.  I will say that it seemed to handle the initialization better than the previous version.
Comment 6 Craig Lanning 2012-08-10 16:02:32 EDT
I've been running this daily for the last week and it seems to be much more stable than the previous version and I'm not seeing any lost messages.
Comment 7 Milan Crha 2012-08-13 04:41:00 EDT
Good, thanks for the update. There was a release of evolution-ews 3.4.4 today, I'll add this bug to the associated update.
Comment 8 Fedora Update System 2012-08-13 06:21:30 EDT
evolution-ews-3.4.4-1.fc17,evolution-mapi-3.4.4-1.fc17,evolution-exchange-3.4.4-1.fc17,evolution-3.4.4-1.fc17,evolution-data-server-3.4.4-1.fc17,gtkhtml3-4.4.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/evolution-ews-3.4.4-1.fc17,evolution-mapi-3.4.4-1.fc17,evolution-exchange-3.4.4-1.fc17,evolution-3.4.4-1.fc17,evolution-data-server-3.4.4-1.fc17,gtkhtml3-4.4.4-1.fc17
Comment 9 Fedora Update System 2012-08-13 21:01:40 EDT
Package evolution-ews-3.4.4-1.fc17, evolution-mapi-3.4.4-1.fc17, evolution-exchange-3.4.4-1.fc17, evolution-3.4.4-1.fc17, evolution-data-server-3.4.4-1.fc17, gtkhtml3-4.4.4-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing evolution-ews-3.4.4-1.fc17 evolution-mapi-3.4.4-1.fc17 evolution-exchange-3.4.4-1.fc17 evolution-3.4.4-1.fc17 evolution-data-server-3.4.4-1.fc17 gtkhtml3-4.4.4-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11822/evolution-ews-3.4.4-1.fc17,evolution-mapi-3.4.4-1.fc17,evolution-exchange-3.4.4-1.fc17,evolution-3.4.4-1.fc17,evolution-data-server-3.4.4-1.fc17,gtkhtml3-4.4.4-1.fc17
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-08-17 21:28:30 EDT
Package evolution-data-server-3.4.4-2.fc17, evolution-ews-3.4.4-1.fc17, evolution-mapi-3.4.4-1.fc17, evolution-exchange-3.4.4-1.fc17, evolution-3.4.4-1.fc17, gtkhtml3-4.4.4-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing evolution-data-server-3.4.4-2.fc17 evolution-ews-3.4.4-1.fc17 evolution-mapi-3.4.4-1.fc17 evolution-exchange-3.4.4-1.fc17 evolution-3.4.4-1.fc17 gtkhtml3-4.4.4-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11822/evolution-ews-3.4.4-1.fc17,evolution-mapi-3.4.4-1.fc17,evolution-exchange-3.4.4-1.fc17,evolution-3.4.4-1.fc17,evolution-data-server-3.4.4-2.fc17,gtkhtml3-4.4.4-1.fc17
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-09-03 18:55:13 EDT
evolution-data-server-3.4.4-2.fc17, evolution-ews-3.4.4-1.fc17, evolution-mapi-3.4.4-1.fc17, evolution-exchange-3.4.4-1.fc17, evolution-3.4.4-1.fc17, gtkhtml3-4.4.4-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.