Bug 84511 - kde panel (kicker) icons are oversized
Summary: kde panel (kicker) icons are oversized
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-18 06:13 UTC by Michael Wardle
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-22 10:16:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Wardle 2003-02-18 06:13:46 UTC
Description of problem: 
After upgrading to KDE and redhat-artwork packages from Raw Hide today, the icons on the 
KDE panel at the bottom of the screen are larger than they previously were, making them quite 
fuzzy.  It's almost as if the icons are being permanently "zoomed" 
(see Panel Settings->Appearance). 
 
Version-Release number of selected component (if applicable): 
kdelibs-3.1-7 
kdebase-3.1-7 
redhat-artwork-0.65-1 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Log in to a KDE session 
     
Actual results: 
Icons along bottom of screen are oversized. 
 
Expected results: 
Icons along bottom are their normal size (somewhat smaller). 
 
Additional info:

Comment 1 Ngo Than 2003-02-18 17:04:13 UTC
The default small icon size is now set to 20x20. To set the icon size to 16x16
as previously, you could do it in kcontrol->Appearance->Icons.


Comment 2 Sammy 2003-02-18 19:20:38 UTC
Panel icons seem to default to 32x32 AND in kcontrol-->Appearance-->icons 
the Panel icon size pulldown menu is inaccessible! 

Comment 3 Sammy 2003-02-18 20:07:57 UTC
Furthermore there is no zooming although the icon zooming is enabled. 

Comment 4 Michael Wardle 2003-02-18 22:39:30 UTC
This is still a bug, however, as the icons look terrible at this new size.  This could partly 
be something fixable by the redhat-artwork package, however the other KDE themes would 
still look bad at this size. 
 
I have filed bug 84561 to deal with the inability to change the default icon size. 
 

Comment 5 Michael Wardle 2003-02-18 22:55:35 UTC
In case your panel's configuration is different from mine, try adding launchers for standard 
KDE programs such as konsole, konqueror, kmail, and kate.  This is done by right-clicking on 
the panel, Add->Application Button. 
 
Notice the very blurry edges. 
 

Comment 6 Sammy 2003-02-19 14:30:26 UTC
I compiled kdebase from source rpm and removed the: 
 
              kdebase-3.1-panelbuttonresize.patch 
 
which results in a working panel with 32 point icons and working zooming. I guess 
this patch needs to be modified. By the way, the icons were 48x48 and stuck at 
that size. 

Comment 7 Sammy 2003-02-21 21:08:18 UTC
The problem is still present in kdebase-3.1-8. 

Comment 8 Sammy 2003-02-24 15:59:01 UTC
Ditto with kdebase-3.1-9....what does the panelbuttonresize patch fix? 

Comment 9 Zack Cerza 2004-07-21 19:32:36 UTC
Does the problem still exist in current versions?

Comment 10 Ngo Than 2004-07-22 10:16:10 UTC
it's fixed in current FC2


Note You need to log in before you can comment on or make changes to this bug.