Bug 845120 - JMX plugin has moved some classes, other plugins may rely on
JMX plugin has moved some classes, other plugins may rely on
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- Other (Show other bugs)
JON 3.1.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: JON 3.1.1
Assigned To: Heiko W. Rupp
Mike Foley
:
Depends On: 845118
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 16:36 EDT by Heiko W. Rupp
Modified: 2013-09-11 06:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 845118
Environment:
Last Closed: 2013-09-11 06:58:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko W. Rupp 2012-08-01 16:36:18 EDT
+++ This bug was initially created as a clone of Bug #845118 +++

Description of problem:

Plugins like Infinispan plugin may fail with 

java.lang.Exception: Discovery component invocation failed.
        at org.rhq.core.pc.util.DiscoveryComponentProxyFactory$ComponentInvocationThread.call(DiscoveryComponentProxyFactory.java:297)
  [...]
Caused by: java.lang.NoClassDefFoundError: org/rhq/plugins/jmx/ObjectNameQueryUtility
        at org.infinispan.rhq.CacheManagerDiscovery.createDiscoveredResource(CacheManagerDiscovery.java:76)
        at org.infinispan.rhq.CacheManagerDiscovery.discoverResources(CacheManagerDiscovery.java:62)


Turns out we moved the ObjectNameQueryUtility to the util sub-package in commit
d06bde3ab789c06f603836525d7281e7a96bad85 on 2012-01-20

--- Additional comment from hrupp@redhat.com on 2012-08-01 16:35:17 EDT ---

master 4f60260d2afe0
Comment 1 Mike Foley 2012-08-01 17:04:35 EDT
We should rather make sure, that we don't make such incompatible changes. Those classes are "the public api" of the JMX plugin.

Can we add a unit-test to hold this public API of the JMX plugin constant?
Can we change the animal-sniffer to detect changes in the public API of the JMX plugin?

I would truly like to prevent the introduction of further regressiosn of this type.
Comment 2 Mike Foley 2012-08-01 17:08:29 EDT
also ... can we do a code search to identify what other plugins may have regerssed because of this change?
Comment 3 Mike Foley 2012-08-01 17:43:09 EDT
task for the QE countermeasure.  https://engineering.redhat.com/trac/jon/ticket/253

i would also like a dev countermeasure included here  ...
Comment 4 Heiko W. Rupp 2012-08-02 12:16:39 EDT
release branch af6c7aa
Comment 5 John Sanda 2012-08-13 22:16:32 EDT
Moving to ON_QA since JON 3.1.1 ER2 build is availble - https://brewweb.devel.redhat.com/buildinfo?buildID=228250
Comment 6 Mike Foley 2012-08-31 14:50:25 EDT
dev added an api diff checker to take care of this.

Note You need to log in before you can comment on or make changes to this bug.