Bug 845151 - [abrt] gimp-2.8.0-1.fc17: g_logv: Process /usr/bin/gimp-2.8 was killed by signal 5 (SIGTRAP)
[abrt] gimp-2.8.0-1.fc17: g_logv: Process /usr/bin/gimp-2.8 was killed by sig...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
abrt_hash:8a2ba87b4bf307e2601a5ce4526...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 21:33 EDT by Jeff Peeler
Modified: 2012-11-14 10:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-14 10:49:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (39.21 KB, text/plain)
2012-08-01 21:33 EDT, Jeff Peeler
no flags Details
File: maps (46.65 KB, text/plain)
2012-08-01 21:33 EDT, Jeff Peeler
no flags Details
File: dso_list (8.87 KB, text/plain)
2012-08-01 21:34 EDT, Jeff Peeler
no flags Details
abrt log (108.57 KB, text/plain)
2012-08-02 12:19 EDT, Jeff Peeler
no flags Details

  None (edit)
Description Jeff Peeler 2012-08-01 21:33:53 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        gimp-2.8 /home/jpeeler/Documents/irmo/check/water.jpg
comment:        Was just resizing the brush / moving the toolbar
crash_function: g_logv
executable:     /usr/bin/gimp-2.8
kernel:         3.4.6-2.fc17.x86_64
pid:            2015
pwd:            /home/jpeeler
remote_result:  691795
time:           Wed 01 Aug 2012 09:20:14 PM EDT
uid:            1000
username:       jpeeler

backtrace:      Text file, 40148 bytes
dso_list:       Text file, 9084 bytes
maps:           Text file, 47770 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/jpeeler/2

core_backtrace:
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x4e801 g_logv libglib-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x4e992 g_log libglib-2.0.so.0 -
:fd952473da735f9c0f50de231aa3d84d7855ef57 0x6a238 - libgdk-x11-2.0.so.0 -
:48c0fe9b8cd26b4d0b5bf1de0bc76da565bd7d27 0x45526 _XError libX11.so.6 -
:48c0fe9b8cd26b4d0b5bf1de0bc76da565bd7d27 0x42771 - libX11.so.6 -
:48c0fe9b8cd26b4d0b5bf1de0bc76da565bd7d27 0x427b5 - libX11.so.6 -
:48c0fe9b8cd26b4d0b5bf1de0bc76da565bd7d27 0x43045 _XEventsQueued libX11.so.6 -
:48c0fe9b8cd26b4d0b5bf1de0bc76da565bd7d27 0x245fa XFlush libX11.so.6 -
:fd952473da735f9c0f50de231aa3d84d7855ef57 0x42410 gdk_window_process_all_updates libgdk-x11-2.0.so.0 -
:23d1440088fed14354e355ac2cbdba1f38fcf1a3 0xc0fb1 - libgtk-x11-2.0.so.0 -
:fd952473da735f9c0f50de231aa3d84d7855ef57 0x1eb97 - libgdk-x11-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x47695 g_main_context_dispatch libglib-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x479c8 - libglib-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x47dc2 g_main_loop_run libglib-2.0.so.0 -
:fd3b4b06b698fed8a4803cb4e7d1e5b153f36c79 0xb8e98 app_run [pie] -
:fd3b4b06b698fed8a4803cb4e7d1e5b153f36c79 0xb8946 main [pie] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=jbp-laptop
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:QTDIR=/usr/lib64/qt-3.3
:GNOME_KEYRING_CONTROL=/run/user/jpeeler/keyring-rPllpB
:QTINC=/usr/lib64/qt-3.3/include
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=jpeeler
:USERNAME=jpeeler
:MAIL=/var/spool/mail/jpeeler
:PATH=/usr/lib64/qt-3.3/bin:/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/jpeeler/.local/bin:/home/jpeeler/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/jpeeler
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1402
:LANG=en_US.UTF-8
:'PS1=[\\u@\\h \\W$(__git_ps1 \" (%s)\")]\\$ '
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/jpeeler
:SHLVL=1
:LOGNAME=jpeeler
:QTLIB=/usr/lib64/qt-3.3/lib
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-fE850mEesH,guid=1613acd4c51d7784d159445400000016
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/jpeeler
:DISPLAY=:0.0
:CCACHE_HASHDIR=
:XAUTHORITY=/var/run/gdm/auth-for-jpeeler-vDlhUJ/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1406,unix/unix:/tmp/.ICE-unix/1406
:GPG_AGENT_INFO=/run/user/jpeeler/keyring-rPllpB/gpg:0:1
:SSH_AUTH_SOCK=/run/user/jpeeler/keyring-rPllpB/ssh
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/gimp.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=2015
:DESKTOP_STARTUP_ID=nautilus-1999-jbp-laptop-gimp-2.8-0_TIME69412

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 30533                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       30533                30533                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/jpeeler/.xsession-errors
:pos:	5226
:flags:	0102002
:2:/home/jpeeler/.xsession-errors
:pos:	5226
:flags:	0102002
:3:socket:[28155]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:socket:[28157]
:pos:	0
:flags:	02004002
:6:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:7:socket:[28159]
:pos:	0
:flags:	02004002
:8:anon_inode:inotify
:pos:	0
:flags:	02004000
:9:pipe:[30769]
:pos:	0
:flags:	00
:10:/home/jpeeler/.gimp-2.8/gimpswap.2015
:pos:	57000704
:flags:	0100002

var_log_messages:
:Jul 31 11:18:20 jbp-laptop yum[16409]: Installed: 2:gimp-2.8.0-1.fc17.x86_64
:Aug  1 21:12:02 jbp-laptop kernel: [215496.362764] gimp-2.8[8784]: segfault at 2 ip 00007f556fe829e6 sp 00007fffffcca7a0 error 4 in gimp-2.8[7f556fb17000+580000]
:Aug  1 21:12:03 jbp-laptop abrt[11122]: Saved core dump of pid 8784 (/usr/bin/gimp-2.8) to /var/spool/abrt/ccpp-2012-08-01-21:12:02-8784 (168304640 bytes)
:Aug  1 21:20:14 jbp-laptop kernel: [  456.620775] gimp-2.8[2015] trap int3 ip:7fa80e8b9801 sp:7fff628a5000 error:0
:Aug  1 21:20:15 jbp-laptop abrt[3057]: Saved core dump of pid 2015 (/usr/bin/gimp-2.8) to /var/spool/abrt/ccpp-2012-08-01-21:20:14-2015 (164507648 bytes)
Comment 1 Jeff Peeler 2012-08-01 21:33:56 EDT
Created attachment 601851 [details]
File: backtrace
Comment 2 Jeff Peeler 2012-08-01 21:33:58 EDT
Created attachment 601852 [details]
File: maps
Comment 3 Jeff Peeler 2012-08-01 21:34:00 EDT
Created attachment 601853 [details]
File: dso_list
Comment 4 Nils Philippsen 2012-08-02 09:55:40 EDT
(In reply to comment #0)
> comment:        Was just resizing the brush / moving the toolbar

Can you reproduce this behavior and/or describe this in more detail?

Something seems to have triggered a BadAlloc response from the X server:

#2  0x00007fa81245f238 in gdk_x_error (display=<optimized out>, error=<optimized out>) at gdkmain-x11.c:486
        buf = "BadAlloc (insufficient resources for operation)", '\000' <repeats 16 times>
        msg = <optimized out>
#3  0x00007fa80e1bf526 in _XError (dpy=dpy@entry=0x7fa8148e9870, rep=rep@entry=0x7fa815e02fb0) at XlibInt.c:1583
        rtn_val = <optimized out>

This means the X server run out of a resource (probably a pixmap, request code 53). If you can reproduce the problem, please run gimp from the command line with the option "--sync" and re-generate the backtrace -- this will process X protocol requests synchronously and therefore should provide more detail on what the application tried to do. Thanks!
Comment 5 Jeff Peeler 2012-08-02 12:13:46 EDT
I dragged the tool options into the main area that says "you can drop dockable dialogs here". I then closed the floating toolbox. Next I tried to drag the tool options back outside of the main window, expecting that whatever window needed to be created for it to attach to would spawn itself.

backtrace_rating: 4
Package: gimp-2.8.0-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 6 Jeff Peeler 2012-08-02 12:19:59 EDT
Created attachment 601993 [details]
abrt log

The backtraces look the same with the --sync option, but here's everything again.
Comment 8 Nils Philippsen 2012-11-13 11:12:00 EST
Jeff, sorry it took me so long.

Anyway, it looks like GIMP tries to create a pixmap of 1140x59699 pixels which looks a bit large to me. What are the dimensions of your screen? When this happens, I take it that GIMP in multi window mode -- are any of the windows maximized, or have a very large height?
Comment 9 Jeff Peeler 2012-11-13 15:25:49 EST
It's ok, stuff happens.

It appears that this problem has been fixed. But for the record, none of the windows were maximized. This was actually in single-window mode, with a resolution of 1920x1080. I don't use gimp that often, so it could have been fixed a while ago. I think it's safe to close now though.
Comment 10 Nils Philippsen 2012-11-14 10:49:23 EST
Thanks for the quick reply!

I can't imagine why GIMP would want to create such a large pixmap, but good that it's fixed (or at least seem to be). I'll close this for now, if it happens again please reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.