Bug 84516 - X still not supporting i830 fully
X still not supporting i830 fully
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
phoebe
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-18 03:34 EST by Justin Georgeson
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-24 21:30:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -v (3.22 KB, text/plain)
2003-02-18 03:35 EST, Justin Georgeson
no flags Details
XFree86.0.log (45.12 KB, text/plain)
2003-02-18 03:36 EST, Justin Georgeson
no flags Details
XF86Config (3.01 KB, text/plain)
2003-02-18 03:37 EST, Justin Georgeson
no flags Details

  None (edit)
Description Justin Georgeson 2003-02-18 03:34:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030120

Description of problem:
I have an up2date (as of 20030218) phoebe install, running kernel 2.4.20-2.24
and XFree86  4.2.99.3-20030118.3. I'm running on a Dell Latitute C400 with an
Intel i830. One thing that strikes me is I can't seem to find a command-line X
configuration tool, did I miss a package? My problem is the all too common
stolen memory issue, I think. I tried both 24 and 8 bit 1024x768, both said the
screens found didn't have valid configurations. I have my config file, the log
file, and the lspci -v output which I will attach to this bug.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set resolution to 1024x768 with any color depth
2. start X
    

Actual Results:  X fails to load, saying configured screens have invalid
configurations

Expected Results:  X should start in the specified resolution and color depth

Additional info:
Comment 1 Justin Georgeson 2003-02-18 03:35:46 EST
Created attachment 90149 [details]
lspci -v
Comment 2 Justin Georgeson 2003-02-18 03:36:36 EST
Created attachment 90150 [details]
XFree86.0.log
Comment 3 Justin Georgeson 2003-02-18 03:37:13 EST
Created attachment 90151 [details]
XF86Config
Comment 4 Mike A. Harris 2003-02-19 02:07:55 EST
The "stolen memory" issue, is a BIOS bug, not an XFree86 bug, and it is
worked around in current XFree86 CVS.

(II) I810(0): BIOS now sees 8000 kB VideoRAM
(--) I810(0): Pre-allocated VideoRAM: 892 kByte
(==) I810(0): VideoRAM: 32768 kByte

32Mb of memory is what the driver sees.  
Comment 5 Mike A. Harris 2003-02-19 02:15:23 EST
The Red Hat X configuration tool is redhat-config-xfree86.  It works both
from the commandline, and as a GUI app.  Run it as:

redhat-config-xfree86 --help

to get a list of options for use from the commandline.  Use --reconfig
to have it generate a new config from scratch.

XFree86 Version 4.2.99.3 (Red Hat Linux release: 4.2.99.3-20030118.3) / X Window
System
(protocol Version 11, revision 0, vendor release 6600)


This X build is quite old, and a large number of bugs have been fixed since
then.  XFree86 4.2.99.4, 4.2.99.901, and 4.2.99.902 have been released
since then.  Please upgrade your system to the latest beta, and latest
rawhide packages, as many many bugs have been fixed since 4.2.99.3.
Comment 6 Justin Georgeson 2003-02-19 11:35:38 EST
Ok, I have th config package installed now, but it's not working on the command
line, I'll file another bug for that.

I'm trying to use Phoebe to avoid mixing up a released disrtibution with Raw
Hide RPMs. There's been recen discussion on the phoebe mailing list that there
is likely a new beta being pushed to the ftp site. Do you know if the most
recent X RPMs from Rawhide will be in it? If so I'll just wait for that.
Comment 7 Justin Georgeson 2003-02-24 12:52:45 EST
I upgraded to 8.0.94, and it's working fine. I did have manually run
redhat-config-xfree86 to specify my monitor type (set it to "Dell 1024X Laptop
Display"), I'm guessing that was the problem all along.
Comment 8 Mike A. Harris 2003-02-24 21:30:01 EST
Ok thanks, closing as RAWHIDE

Note You need to log in before you can comment on or make changes to this bug.