Bug 845179 - direct lun: fails start vm because of udev rules not loaded before create symlink
direct lun: fails start vm because of udev rules not loaded before create sym...
Status: CLOSED DUPLICATE of bug 844130
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.4
Assigned To: Dan Kenigsberg
Haim
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-02 02:38 EDT by Royce Lv
Modified: 2016-02-10 11:56 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-02 03:17:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Royce Lv 2012-08-02 02:38:31 EDT
Description of problem:
start vm with direct lun fails because of udev rules not loaded before making dev symlink:

Thread-143::DEBUG::2012-07-30 13:50:12,204::BindingXMLRPC::888::vds::(wrapper) return f with {'status': {'message': 'Done', 'code': 0}, 'vmList': {'status': 'WaitForLaunch', 'acpiEnable': 'true', 'emulatedMachine': 'pc-0.14', 'tabletEnable': 'true', 'pid': '0', 'timeOffset': '0', 'displayPort': '-1', 'displaySecurePort': '-1', 'spiceSslCipherSuite': 'DEFAULT', 'cpuType': 'Conroe', 'custom': {'device_67de7f2f-a638-4f45-beda-cd2e3ca5a0e4device_4345f7ef-3c42-4a59-aa50-dddeeb6ebd80device_4141e99b-4abc-4101-a158-3146f8f3d53b': 'VmId=fb4ec2a4-94ff-44ec-a79f-641a3853d67c,DeviceId=4141e99b-4abc-4101-a158-3146f8f3d53b,Device=virtio-serial,Type=controller,BootOrder=0,SpecParams={},Address={bus=0x00, domain=0x0000, type=pci, slot=0x03, function=0x0},IsManaged=false,IsPlugged=true,IsReadOnly=false,alias=virtio-serial0', 'device_67de7f2f-a638-4f45-beda-cd2e3ca5a0e4device_4345f7ef-3c42-4a59-aa50-dddeeb6ebd80device_4141e99b-4abc-4101-a158-3146f8f3d53bdevice_45893163-cd2b-4f91-9143-e976e61987a0': 'VmId=fb4ec2a4-94ff-44ec-a79f-641a3853d67c,DeviceId=45893163-cd2b-4f91-9143-e976e61987a0,Device=unix,Type=channel,BootOrder=0,SpecParams={},Address={port=1, bus=0, controller=0, type=virtio-serial},IsManaged=false,IsPlugged=true,IsReadOnly=false,alias=channel0', 'device_67de7f2f-a638-4f45-beda-cd2e3ca5a0e4': 'VmId=fb4ec2a4-94ff-44ec-a79f-641a3853d67c,DeviceId=67de7f2f-a638-4f45-beda-cd2e3ca5a0e4,Device=usb,Type=controller,BootOrder=0,SpecParams={},Address={bus=0x00, domain=0x0000, type=pci, slot=0x01, function=0x2},IsManaged=false,IsPlugged=true,IsReadOnly=false,alias=usb0', 'device_67de7f2f-a638-4f45-beda-cd2e3ca5a0e4device_4345f7ef-3c42-4a59-aa50-dddeeb6ebd80': 'VmId=fb4ec2a4-94ff-44ec-a79f-641a3853d67c,DeviceId=4345f7ef-3c42-4a59-aa50-dddeeb6ebd80,Device=ide,Type=controller,BootOrder=0,SpecParams={},Address={bus=0x00, domain=0x0000, type=pci, slot=0x01, function=0x1},IsManaged=false,IsPlugged=true,IsReadOnly=false,alias=ide0'}, 'clientIp': '', 'nicModel': 'rtl8139,pv', 'keyboardLayout': 'en-us', 'kvmEnable': 'true', 'vmId': 'fb4ec2a4-94ff-44ec-a79f-641a3853d67c', 'transparentHugePages': 'true', 'devices': [{'device': 'qxl', 'specParams': {'vram': '65536'}, 'type': 'video', 'deviceId': 'cf172ead-17a2-45bd-9cf5-7ea6db36f5bd', 'address': {'bus': '0x00', ' slot': '0x02', ' domain': '0x0000', ' type': 'pci', ' function': '0x0'}}, {'index': '2', 'iface': 'ide', 'specParams': {'path': ''}, 'readonly': 'true', 'deviceId': '54207b82-db00-4b8d-b344-201dafbdf0df', 'address': {' controller': '0', ' target': '0', 'unit': '0', ' bus': '1', ' type': 'drive'}, 'device': 'cdrom', 'path': '', 'type': 'disk'}, {'index': '0', 'iface': 'virtio', 'format': 'raw', 'type': 'disk', 'specParams': {}, 'readonly': 'false', 'deviceId': '35d77c63-25db-4181-80ea-5332682b35f8', 'propagateErrors': 'off', 'address': {'bus': '0x00', ' slot': '0x04', ' domain': '0x0000', ' type': 'pci', ' function': '0x0'}, 'device': 'disk', 'shared': 'false', 'GUID': '1IET_00020001', 'optional': 'false'}, {'device': 'usb', 'specParams': {}, 'type': 'controller', 'deviceId': '67de7f2f-a638-4f45-beda-cd2e3ca5a0e4', 'address': {'bus': '0x00', ' slot': '0x01', ' domain': '0x0000', ' type': 'pci', ' function': '0x2'}}, {'device': 'memballoon', 'specParams': {'model': 'virtio'}, 'type': 'balloon', 'deviceId': '4c2e3f27-29bc-458a-967b-c8171458e306'}], 'smp': '1', 'vmType': 'kvm', 'memSize': 512, 'displayIp': '0', 'spiceSecureChannels': 'smain,sinputs,scursor,splayback,srecord,sdisplay', 'smpCoresPerSocket': '1', 'vmName': 'testserver3', 'display': 'vnc', 'nice': '0'}}
MainProcess|Thread-144::DEBUG::2012-07-30 13:50:12,210::supervdsmServer::219::SuperVdsm.ServerCallback::(appropriateDevice) ruleFile: /etc/udev/rules.d/99-vdsm-1IET_00020001-fb4ec2a4-94ff-44ec-a79f-641a3853d67c.rules!!!!!!!!!!!!!!!!
MainProcess|Thread-144::DEBUG::2012-07-30 13:50:12,211::supervdsmServer::228::SuperVdsm.ServerCallback::(appropriateDevice) write successful!!!!!!!!!!!!!!!!!
MainProcess|Thread-144::DEBUG::2012-07-30 13:50:12,212::__init__::1249::Storage.Misc.excCmd::(_log) '/usr/bin/udevadm trigger --verbose --action change --property-match=DM_NAME=1IET_00020001' (cwd None)
MainProcess|Thread-144::DEBUG::2012-07-30 13:50:12,286::__init__::1249::Storage.Misc.excCmd::(_log) SUCCESS: <err> = ''; <rc> = 0
Thread-144::INFO::2012-07-30 13:50:12,413::logUtils::39::dispatcher::(wrapper) Run and protect: appropriateDevice, Return response: None
Thread-144::DEBUG::2012-07-30 13:50:12,414::task::1151::TaskManager.Task::(prepare) Task=`ac9c4d38-6f8a-4af6-9ab4-83eda30a264b`::finished: None
Thread-144::DEBUG::2012-07-30 13:50:12,414::task::568::TaskManager.Task::(_updateState) Task=`ac9c4d38-6f8a-4af6-9ab4-83eda30a264b`::moving from state preparing -> state finished
Thread-144::DEBUG::2012-07-30 13:50:12,415::resourceManager::809::ResourceManager.Owner::(releaseAll) Owner.releaseAll requests {} resources {}
Thread-144::DEBUG::2012-07-30 13:50:12,415::resourceManager::844::ResourceManager.Owner::(cancelAll) Owner.cancelAll requests {}
Thread-144::DEBUG::2012-07-30 13:50:12,415::task::957::TaskManager.Task::(_decref) Task=`ac9c4d38-6f8a-4af6-9ab4-83eda30a264b`::ref 0 aborting False
Thread-144::INFO::2012-07-30 13:50:12,415::clientIF::293::vds::(prepareVolumePath) prepared volume path: /dev/mapper/1IET_00020001
Thread-144::DEBUG::2012-07-30 13:50:12,421::libvirtvm::1335::vm.Vm::(_run) vmId=`fb4ec2a4-94ff-44ec-a79f-641a3853d67c`::<?xml version="1.0" encoding="utf-8"?>
<domain type="kvm">
	<name>testserver3</name>
	<uuid>fb4ec2a4-94ff-44ec-a79f-641a3853d67c</uuid>
	<memory>524288</memory>
	<currentMemory>524288</currentMemory>
	<vcpu>1</vcpu>
	<devices>
		<channel type="unix">
			<target name="com.redhat.rhevm.vdsm" type="virtio"/>
			<source mode="bind" path="/var/lib/libvirt/qemu/channels/testserver3.com.redhat.rhevm.vdsm"/>
		</channel>
		<input bus="usb" type="tablet"/>
		<graphics autoport="yes" keymap="en-us" listen="0" passwd="*****" passwdValidTo="1970-01-01T00:00:01" port="-1" type="vnc"/>
		<console type="pty">
			<target port="0" type="virtio"/>
		</console>
		<controller type="usb">
			<address  domain="0x0000"  function="0x2"  slot="0x01"  type="pci" bus="0x00"/>
		</controller>
		<video>
			<address  domain="0x0000"  function="0x0"  slot="0x02"  type="pci" bus="0x00"/>
			<model heads="1" type="qxl" vram="65536"/>
		</video>
		<memballoon model="virtio"/>
		<disk device="cdrom" snapshot="no" type="file">
			<address  bus="1"  controller="0"  target="0"  type="drive" unit="0"/>
			<source file="" startupPolicy="optional"/>
			<target bus="ide" dev="hdc"/>
			<readonly/>
			<serial></serial>
		</disk>
		<disk device="disk" snapshot="no" type="block">
			<address  domain="0x0000"  function="0x0"  slot="0x04"  type="pci" bus="0x00"/>
			<source dev="/dev/mapper/1IET_00020001"/>
			<target bus="virtio" dev="vda"/>
			<serial></serial>
			<driver cache="none" error_policy="stop" io="native" name="qemu" type="raw"/>
		</disk>
	</devices>
	<os>
		<type arch="x86_64" machine="pc-0.14">hvm</type>
		<smbios mode="sysinfo"/>
	</os>
	<sysinfo type="smbios">
		<system>
			<entry name="manufacturer">Red Hat</entry>
			<entry name="product">RHEV Hypervisor</entry>
			<entry name="version">17-1</entry>
			<entry name="serial">012B83FC-D250-CB11-8A7C-BF569899FB73_f0:de:f1:5a:0b:0a</entry>
			<entry name="uuid">fb4ec2a4-94ff-44ec-a79f-641a3853d67c</entry>
		</system>
	</sysinfo>
	<clock adjustment="0" offset="variable">
		<timer name="rtc" tickpolicy="catchup"/>
	</clock>
	<features>
		<acpi/>
	</features>
	<cpu match="exact">
		<model>Conroe</model>
		<topology cores="1" sockets="1" threads="1"/>
	</cpu>
</domain>

Thread-144::DEBUG::2012-07-30 13:50:12,966::vm::576::vm.Vm::(_startUnderlyingVm) vmId=`fb4ec2a4-94ff-44ec-a79f-641a3853d67c`::_ongoingCreations released
Thread-144::ERROR::2012-07-30 13:50:12,967::vm::600::vm.Vm::(_startUnderlyingVm) vmId=`fb4ec2a4-94ff-44ec-a79f-641a3853d67c`::The vm start process failed
Traceback (most recent call last):
  File "/usr/share/vdsm/vm.py", line 566, in _startUnderlyingVm
    self._run()
  File "/usr/share/vdsm/libvirtvm.py", line 1361, in _run
    self._connection.createXML(domxml, flags),
  File "/usr/lib64/python2.7/site-packages/vdsm/libvirtconnection.py", line 82, in wrapper
    ret = f(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 2420, in createXML
    if ret is None:raise libvirtError('virDomainCreateXML() failed', conn=self)
libvirtError: Internal Error Process exited while reading console log output: char device redirected to /dev/pts/8
qemu-kvm: -drive file=/dev/mapper/1IET_00020001,if=none,id=drive-virtio-disk0,format=raw,serial=,cache=none,werror=stop,rerror=stop,aio=native: could not open disk image /dev/mapper/1IET_00020001: Permission denied

Thread-144::DEBUG::2012-07-30 13:50:12,997::vm::916::vm.Vm::(setDownStatus) vmId=`fb4ec2a4-94ff-44ec-a79f-641a3853d67c`::Changed state to Down: Internal error Process exited while reading console log output: char device redirected to /dev/pts/8
qemu-kvm: -drive file=/dev/mapper/1IET_00020001,if=none,id=drive-virtio-disk0,format=raw,serial=,cache=none,werror=stop,rerror=stop,aio=native: could not open disk image /dev/mapper/1IET_00020001: Permission denied
Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.create a empty vm with engine
2.add a external disk for this vm
3.start vm
  
Actual results:
start vm fails

Expected results:
start vm smoothly

Additional info:
Comment 1 Itamar Heim 2012-08-02 03:08:00 EDT
isn't a duplicate of bug 844130 also reported by you?
Comment 2 Royce Lv 2012-08-02 03:17:01 EDT
(In reply to comment #1)
> isn't a duplicate of bug 844130 also reported by you?
Sorry , I thought I haven't opened one when people asked me about the patch background in gerrit.

*** This bug has been marked as a duplicate of bug 844130 ***

Note You need to log in before you can comment on or make changes to this bug.