Bug 845258 - rhui-manager status displays repo error while repo sync is in progress
rhui-manager status displays repo error while repo sync is in progress
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1
Unspecified Unspecified
high Severity unspecified
: ---
: 2.1.3
Assigned To: dgao
Ina Panova
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-02 09:30 EDT by mkovacik
Modified: 2014-11-25 19:35 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
This update fixes the detection of the difference between a repository having not been synchronized before or it having an error from the previous synchronization. This meant that a newly added repository would display as 'Error' in the synchronization history until its first synchronization was completed. The logic has been updated to account for a special case were the repository is new and it has no previous synchronization history. This change means the synchronization status is more accurate.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-17 15:09:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen log (11.68 KB, text/plain)
2012-08-02 09:30 EDT, mkovacik
no flags Details

  None (edit)
Description mkovacik 2012-08-02 09:30:48 EDT
Created attachment 601949 [details]
Screen log

Description of problem:
The rhui-manager displays repo status as Error while the repo content is being synced.

Version-Release number of selected component (if applicable):
 - Build: RHEL-6.3-RHUI-2.1-20120801.0-Server-x86_64-DVD1.iso
 - rh-rhui-tools: 2.1.7

How reproducible:
1 of 1

Steps to Reproduce:
1. add a larger Red Hat repository (6 server)
2. issue synchronization of the repository
3. quit rhui manager
4. rhui-manager status shows error where sync should be displayed
  
Actual results:
Error repo status shown instead of Synchronization

Expected results:
Error repo status not shown while the repo synchronization is ongoing 

Additional info:
See the screen log attached
Comment 1 James Slagle 2012-08-02 09:37:16 EDT
this is a pre-existing problem.  when new repos are added, their initial status from the status command shows error instead of unknown.

I don't think this needs to be fixed for 2.1.
Comment 2 wes hayutin 2012-08-06 20:05:11 EDT
moving to 2.1.1
Comment 3 dgao 2013-09-25 17:35:28 EDT
Commit: a1eaa5f6def2e6e8040f3ce4c039d080762241f7

Instead of error during sync, it should now have [  SYNCING  ] state.
Comment 4 Ina Panova 2013-11-04 06:52:41 EST
tested in
rh-rhui-tools-2.1.27-1.el6_4.noarch
pulp-0.0.263-38.el6_4.noarch

Move to Verified.
Comment 6 errata-xmlrpc 2013-12-17 15:09:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1854.html

Note You need to log in before you can comment on or make changes to this bug.