Bug 845265 - [RFE] practical use of the proxy options to subscription-manager modules
[RFE] practical use of the proxy options to subscription-manager modules
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 7.0
Assigned To: candlepin-bugs
IDM QE LIST
: FutureFeature
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-08-02 09:52 EDT by John Sefler
Modified: 2013-08-06 11:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-06 11:05:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-08-02 09:52:53 EDT
Description of problem:
Many of the subscription-manager CLI modules have optional parameters for --proxy --proxyuser and --proxypassword.  When using these parameters on the command line, they are NOT persisted to the rhsm.conf file.  Instead, they override their corresponding values set in the rhsm.conf.  While I believe this is the correct behavior for an optional cli argument, it is not practical and it is NOT how rhnreg_ks handles the proxy options.  Like rhnreg_ks, it is more practical to persist the value of the specified proxy options to the rhsm.conf file when used during a call to subscription-manager register.

If you agree with these statements and decide to fix this bug, then I also believe you should apply the the same fixes as detailed in Bug 842768 and limit the --proxy --proxyuser and --proxypassword options to these modules:
  register
  redeem
  orgs
  environments
  service-level


Version-Release number of selected component (if applicable):
[root@jsefler-rhel59 ~]# rpm -q subscription-manager
subscription-manager-1.0.11-1.git.11.4d6cb5a.el5
Comment 1 RHEL Product and Program Management 2012-08-02 10:09:03 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Jesus M. Rodriguez 2013-08-06 11:05:11 EDT
(In reply to John Sefler from comment #0)
> Description of problem:
> Many of the subscription-manager CLI modules have optional parameters for
> --proxy --proxyuser and --proxypassword.  When using these parameters on the
> command line, they are NOT persisted to the rhsm.conf file.  Instead, they
> override their corresponding values set in the rhsm.conf.  While I believe
> this is the correct behavior for an optional cli argument, it is not
> practical and it is NOT how rhnreg_ks handles the proxy options.  Like
> rhnreg_ks, it is more practical to persist the value of the specified proxy
> options to the rhsm.conf file when used during a call to
> subscription-manager register.

No I do not think they should be persisted when you pass them in as optional parameters to these commands.

> 
> If you agree with these statements and decide to fix this bug, then I also
> believe you should apply the the same fixes as detailed in Bug 842768 and
> limit the --proxy --proxyuser and --proxypassword options to these modules:
>   register
>   redeem
>   orgs
>   environments
>   service-level

No because the others listed in the bug #842768 require internet connectivity therefore should also have the parameters just in case.

Note You need to log in before you can comment on or make changes to this bug.