Bug 845269 - [lvmetad] Clients segfaulting on incorrect repsone from lvmetad
Summary: [lvmetad] Clients segfaulting on incorrect repsone from lvmetad
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2
Version: 6.3
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Petr Rockai
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On: 845259
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-08-02 14:04 UTC by Marian Csontos
Modified: 2013-02-21 08:13 UTC (History)
11 users (show)

Fixed In Version: lvm2-2.02.98-1.el6
Doc Type: Bug Fix
Doc Text:
When an LVM command encountered a problem talking to lvmetad, the command could crash in certain circumstances. This problem has been fixed.
Clone Of: 845259
Environment:
Last Closed: 2013-02-21 08:13:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
full gbd backtrace (6.38 KB, text/plain)
2012-08-02 14:06 UTC, Marian Csontos
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0501 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2013-02-20 21:30:45 UTC

Description Marian Csontos 2012-08-02 14:04:00 UTC
Description of problem:
Incorrect response from lvmetad is not handled correctly and causes segfault.
Parsing procedure returns NULL pointer which is dereferenced later:

<pre>
    static inline const char *daemon_reply_str(daemon_reply r, const char *path, const      ...|char *def) {
            return dm_config_find_str(r.cft->root, path, def);                              
    }
</pre>

Here the r.cft is 0x0

Version-Release number of selected component (if applicable):
lvm2-2.02.97-0.151

How reproducible:
low reproducibility of original lvmetad bug.
but this would crash 100% of time when wrong data are received.

Steps to Reproduce:
Bug 845259 in lvmetad would crash client.
  
Actual results:
segfault

Expected results:
error message or retry?

Additional info:

Comment 1 Marian Csontos 2012-08-02 14:06:21 UTC
Created attachment 601956 [details]
full gbd backtrace

Comment 3 Petr Rockai 2012-09-26 19:11:34 UTC
This should be fixed upstream now.

Comment 7 Corey Marthaler 2013-01-24 21:21:24 UTC
Have not seen any segfaults during the latest LVM regression testing while running with lvmetad turned on. Marking this verified (SanityOnly).

Comment 8 errata-xmlrpc 2013-02-21 08:13:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0501.html


Note You need to log in before you can comment on or make changes to this bug.