Bug 845273 - Unable to remove custom repo while red hat repo sync in progress
Unable to remove custom repo while red hat repo sync in progress
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1
Unspecified Unspecified
high Severity unspecified
: ---
: 2.1.3
Assigned To: dgao
Ina Panova
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-02 10:13 EDT by mkovacik
Modified: 2013-12-17 15:09 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-17 15:09:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen log (11.19 KB, text/plain)
2012-08-02 10:13 EDT, mkovacik
no flags Details
Screen log 1 (3.14 KB, text/plain)
2012-08-02 10:17 EDT, mkovacik
no flags Details

  None (edit)
Description mkovacik 2012-08-02 10:13:41 EDT
Created attachment 601958 [details]
Screen log

Description of problem:
I can't delete custom repo while red hat repos are being synced.

Version-Release number of selected component (if applicable):
 - Build: RHEL-6.3-RHUI-2.1-20120801.0-Server-x86_64-DVD1.iso

How reproducible:
1 of 1

Steps to Reproduce:
1. add and sync rhel 5 and rhel 6 repos
2. while they're syncing, create custom (unprotected) repo and push content to it
3. while the rhel 5 and 6 repos are still syncing, try to delete the custom repo
4. custom repo not deleted; second retry of the repo fails with "unexpected error" and .rhui/rhui.log shows two stack dumps:
 - cant delete <custom> repo; already in progress
 - <custom> repo can't be deleted 
  
Actual results:
Unable to remove custom repo while sync of (big) rhel repo is in progress

Expected results:
Custom repo is removed OK


Additional info:
See the screen log attached
Comment 1 mkovacik 2012-08-02 10:17:16 EDT
Created attachment 601959 [details]
Screen log 1

Probably not a bug, as the repo eventualy disappeared...
Comment 2 James Slagle 2012-08-09 12:32:15 EDT
we can probably stand to improve the messaging here some to let the user know that the delete has just been queued, and so it didn't happen immediately.  We can look at this for 2.1.1.
Comment 3 Ina Panova 2013-06-27 04:58:44 EDT
Hi,
I've reproduced the bug and it seems that the issue consists in multi-threading. There are only 4 threads available, so when they are occupied, another tasks are queued. As soon as one thread will finish his task it will delete the custom repo awaiting in the queue. So the delete of the custom repo will happen only after the sync that could take pretty much time.
Comment 4 dgao 2013-10-07 10:11:44 EDT
Improved messaging to inform the user that delete task have queued:

cloude: bf040b3579c6888d3ed776f67a9d4ecd94951ae7
Comment 5 Ina Panova 2013-11-04 06:38:30 EST
tested in:
rh-rhui-tools-2.1.27-1.el6_4.noarch
pulp-0.0.263-38.el6_4.noarch

Move to Verified.
Comment 7 errata-xmlrpc 2013-12-17 15:09:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1854.html

Note You need to log in before you can comment on or make changes to this bug.