Bug 845369 - [RFE] Repo group membership should also take a --repo-id argument
[RFE] Repo group membership should also take a --repo-id argument
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
2.0.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Sprint 42
Assigned To: Jay Dobies
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-02 16:02 EDT by Jay Dobies
Modified: 2013-09-09 12:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-09 12:07:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Dobies 2012-08-02 16:02:17 EDT
I like the criteria based approach but after using it I think we should offer a shortcut that explicity takes a repo ID. That argument will stuff the ID into the appropriate place and format in the criteria, but it makes the CLI a bit cleaner.

For instance, I went to add a single repo to a group:

$ pulp-admin repo group members add --group-id comics --str-eq "id=avengers"

I think we can offer a simpler shortcut for this:

$ pulp-admin repo group members add --group-id comics --repo-id avengers

The server-side doesn't have to change, the client just takes the ID and adds it to the criteria as appropriate. I also suggest we make this argument allowable to be specified multiple times, that way I can do:

$ pulp-admin repo group members add --group-id comics --repo-id avengers --repo-id jla

I figure in most cases people will want to add a single repo so it might be nice to offer a simpler way of doing that.
Comment 1 Michael Hrivnak 2012-08-27 18:20:11 EDT
Jay, it looks like you already did this in https://github.com/pulp/pulp/commit/907a806
Comment 2 Jay Dobies 2012-11-28 18:17:32 EST
Mike's right, this was done. Aligning to 2.0 so QE can verify.
Comment 4 Preethi Thomas 2013-01-09 12:07:50 EST
Pulp v2.0 released

Note You need to log in before you can comment on or make changes to this bug.