Bug 84537 - AS3.0 IPF: Inclusion of zx1 hot-plug support
Summary: AS3.0 IPF: Inclusion of zx1 hot-plug support
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 2.1
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Doug Ledford
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-18 16:40 UTC by Larry Troan
Modified: 2016-04-18 09:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-17 14:23:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
HP Winzip patch3.zip (17.52 KB, patch)
2003-02-18 16:41 UTC, Larry Troan
no flags Details | Diff

Description Larry Troan 2003-02-18 16:40:40 UTC
PROBLEM: zx1 hot-plug support not available.

FIX EXISTS in Greg Cage Package; HP would develop: HP is working on zx1 PCI
hot-plug support.  Evaluating device-specific vs. ACPI implementations.  Would
be nice to only do for 2.5, but would consider 2.4 depending on RHAS kernel plans 

BUSINESS CASE: Telco market feature.  Requirement for high-end boxes (where we
support hot-plug everything).  Support of Diablo, Orca, Eiger, and Olympia.

DATE REQUIRED: With 3.0

----------
Action by: charline.polifka
Issue Registered
----------
Action by: ltroan
HP to develop code (on Greg Cage package)

charline.polifka assigned to issue for HP-IPF.

Category set to: Applications
Status set to: Waiting on Client (Long Term)

----------
Action by: charline.polifka
Attached are the patches:
These four patches against 2.4.20 are required to support pci hotplug on Diablo.

PLEASE NOTE:  Further patches are required for ACPI to support hotplug on
Pinnacles-based systems.  These patches are being written by Intel and are not
yet available.

Further patches are required to support HP ACPI extensions to report latch
status and set attention button status.  These patches are not yet available as
no firmware has been released which implements this functionality.

Patch 01 is the changes between 2.4.20 and 2.4.21-pre1 in the acpiphp hotplug
driver.

Patch 02 is required to find the zx1 hotplug controllers.  It requires a version
of ACPI later than that shipped in stock 2.4.20.  That shipped in the
2.4.20-ia64 patch is sufficiently recent.  This patch has been approved by
GregKH but is not accepted into 2.4.21 due to its requirements for a more recent
ACPI.

Patch 03 is required for card insertion.  It implements the Linux 2.5 internal
interface for accessing PCI config space and reimplements the Linux 2.4
interface on top of it.  This patch has been approved by GregKH and accepted
into 2.4.21-pre3.

Patch 04 is also required for card insertion.  It converts the acpiphp driver to
use the new PCI config space accessor interfaces.  This patch has also been
approved by GregKH and accepted into 2.4.21-pre3.


Status set to: Waiting on Tech
File uploaded: HP Winzip patch3.zip


ISSUE TRACKER 11376,opened by HP as sev 1 (Feature for Taroon)

Comment 1 Larry Troan 2003-02-18 16:41:17 UTC
Created attachment 90160 [details]
HP Winzip patch3.zip

Comment 2 Susan Denham 2003-04-15 21:50:28 UTC
Mail sent to Alan Meyer on 4/16 to prompt him to get required ACPI GPE patch
from Robert Moore of Intel.   No progress can be made without this.

Comment 3 Larry Troan 2003-05-27 16:14:01 UTC
Larry gave Bjorn a new kernel last week and Bjorn is verifying that the support
is included.

Comment 6 Doug Ledford 2005-10-17 14:23:32 UTC
This is an old bug report that was a dup of another bug report (although I can't
remember the other bug reports number right now).  Closing this one out.


Note You need to log in before you can comment on or make changes to this bug.